# CVE-2023-45129: matrix-synapse vulnerable to denial of service due to malicious server ACL events


- **Severity:** Medium 4.9 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 10 Oct 2023
- **Updated:** 13 Feb 2025
- **Also known as:** GHSA-5chr-wjw5-3gq4, PYSEC-2023-199, UBUNTU-CVE-2023-45129, openSUSE-SU-2024:13320-1

## What is CVE-2023-45129?

CVE-2023-45129 is a medium-severity vulnerability in Fedoraproject Fedora, published on 10 Oct 2023. 

### Official description

Synapse is an open-source Matrix homeserver written and maintained by the Matrix.org Foundation. Prior to version 1.94.0, a malicious server ACL event can impact performance temporarily or permanently leading to a persistent denial of service. Homeservers running on a closed federation (which presumably do not need to use server ACLs) are not affected. Server administrators are advised to upgrade to Synapse 1.94.0 or later. As a workaround, rooms with malicious server ACL events can be purged and blocked using the admin API.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling)

## Which versions are affected by CVE-2023-45129?

3 open source packages ship an affected version, including matrix-synapse. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `matrix-synapse` | PyPI | All versions | 1.94.0 |
| `matrix-synapse` | PyPI | All versions | 1.94.0 |
| `matrix-synapse` | PyPI | All versions | 1.94.0 |
| `matrix-synapse` | openSUSE:Tumbleweed | All versions | 1.94.0-2.1 |

Products: Fedoraproject Fedora, Matrix Synapse.

## How do I fix CVE-2023-45129?

Upgrade matrix-synapse to 1.94.0 or later.

## Is CVE-2023-45129 being exploited?

There is no known exploitation of CVE-2023-45129 in the wild and no public exploit code.

## Other vulnerabilities in Fedoraproject Fedora

- [CVE-2024-4577](https://insights.sbomify.com/CVE-2024-4577/): PHP-CGI OS Command Injection (critical 9.8, exploited in the wild)
- [CVE-2021-39226](https://insights.sbomify.com/CVE-2021-39226/): Grafana Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2019-5544](https://insights.sbomify.com/CVE-2019-5544/): VMware ESXi and Horizon DaaS OpenSLP Heap-Based Buffer Overflow (critical 9.8, exploited in the wild)
- [CVE-2024-4947](https://insights.sbomify.com/CVE-2024-4947/): Google Chromium V8 Type Confusion (critical 9.6, exploited in the wild)
- [CVE-2024-4671](https://insights.sbomify.com/CVE-2024-4671/): Google Chromium Visuals Use-After-Free (critical 9.6, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-45129 and fix it if it is affected.

What it is: CVE-2023-45129 is a medium-severity vulnerability in Fedoraproject Fedora, published on 10 Oct 2023. 
Exploitation: There is no known exploitation of CVE-2023-45129 in the wild and no public exploit code.

Affected packages and fixed versions:
- matrix-synapse (PyPI): affected all versions; fixed in 1.94.0
- matrix-synapse (PyPI): affected all versions; fixed in 1.94.0
- matrix-synapse (PyPI): affected all versions; fixed in 1.94.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-45129/ (Markdown: https://insights.sbomify.com/CVE-2023-45129/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-45129
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-45129
- OSV: https://osv.dev/vulnerability/CVE-2023-45129

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-45129/
Summaries are generated and may contain mistakes; the official description above is the record.
