CVE-2023-45134 XWiki Platform XSS vulnerability from account in the create page form via template provider
An attacker with an account can inject malicious scripts via template providers, leading to arbitrary code execution and data access for victims who open crafted links.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2023-45134?
CVE-2023-45134 is a critical cross-site scripting vulnerability in Xwiki Xwiki, published on 25 Oct 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Official description
XWiki Platform is a generic wiki platform offering runtime services for applications built on top of it. `org.xwiki.platform:xwiki-platform-web` starting in version 3.1-milestone-1 and prior to 13.4-rc-1, `org.xwiki.platform:xwiki-platform-web-templates` prior to versions 14.10.2 and 15.5-rc-1, and `org.xwiki.platform:xwiki-web-standard` starting in version 2.4-milestone-2 and prior to version 3.1-milestone-1 are vulnerable to cross-site scripting. An attacker can create a template provider on any document that is part of the wiki (could be the attacker's user profile) that contains malicious code. This code is executed when this template provider is selected during document creation which can be triggered by sending the user to a URL. For the attacker, the only requirement is to have an account as by default the own user profile is editable. This allows an attacker to execute arbitrary actions with the rights of the user opening the malicious link. Depending on the rights of the user, this may allow remote code execution and full read and write access to the whole XWiki installation. This has been patched in `org.xwiki.platform:xwiki-platform-web` 13.4-rc-1, `org.xwiki.platform:xwiki-platform-web-templates` 14.10.2 and 15.5-rc-1, and `org.xwiki.platform:xwiki-web-standard` 3.1-milestone-1 by adding the appropriate escaping. The vulnerable template file createinline.vm is part of XWiki's WAR and can be patched by manually applying the changes from the fix.
Weakness: CWE-79
Which versions are affected by CVE-2023-45134?
8 open source packages ship an affected version, including org.xwiki.platform:xwiki-platform-web-templates, org.xwiki.platform:xwiki-platform-web and org.xwiki.platform:xwiki-web-standard. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
org.xwiki.platform:xwiki-platform-web-templates Maven | All versions | 14.10.12 |
org.xwiki.platform:xwiki-platform-web-templates Maven | All versions | 14.10.12 |
org.xwiki.platform:xwiki-platform-web-templates Maven | From 15.0-rc-1 | 15.5-rc-1 |
org.xwiki.platform:xwiki-platform-web-templates Maven | From 15.0-rc-1 | 15.5-rc-1 |
org.xwiki.platform:xwiki-platform-web Maven | From 3.1-milestone-1 | 13.4-rc-1 |
org.xwiki.platform:xwiki-platform-web Maven | From 3.1-milestone-1 | 13.4-rc-1 |
2 more packages
org.xwiki.platform:xwiki-web-standard Maven | From 2.4-milestone-2 | 3.1-milestone-1 |
org.xwiki.platform:xwiki-web-standard Maven | From 2.4-milestone-2 | 3.1-milestone-1 |
Products include Xwiki Xwiki.
How do I fix CVE-2023-45134?
Upgrade org.xwiki.platform:xwiki-platform-web-templates to a fixed version for your release line: 14.10.12 or 15.5-rc-1.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2023-45134 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-45134 exists.
Other vulnerabilities in Xwiki Xwiki
- CVE-2025-24893 XWiki Platform Eval Injection
- CVE-2025-53836 XWiki Rendering is vulnerable to RCE attacks when processing nested macros
- CVE-2024-55662 XWiki allows remote code execution through the extension sheet
- CVE-2024-55877 XWiki allows remote code execution from account through macro descriptions and XWiki.XWikiSyntaxMacrosList
- CVE-2024-37901 XWiki Platform vulnerable to remote code execution from account via SearchSuggestConfigSheet
Sources
Also known as GHSA-gr82-8fj2-ggc3.