# CVE-2023-45136: XWiki Platform web templates vulnerable to reflected XSS in the create document form if name validation is enabled

> Reflected XSS in XWiki allows attackers to execute arbitrary actions and potentially gain full read/write access if name validation is enabled.

- **Severity:** Critical 9.7 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 25 Oct 2023
- **Updated:** 10 Sep 2024
- **Also known as:** GHSA-qcj9-gcpg-4w2w

## What is CVE-2023-45136?

CVE-2023-45136 is a critical cross-site scripting vulnerability in Xwiki Xwiki, published on 25 Oct 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

XWiki Platform is a generic wiki platform offering runtime services for applications built on top of it. When document names are validated according to a name strategy (disabled by default), XWiki starting in version 12.0-rc-1 and prior to versions 12.10.12 and 15.5-rc-1 is vulnerable to a reflected cross-site scripting attack in the page creation form. This allows an attacker to execute arbitrary actions with the rights of the user opening the malicious link. Depending on the rights of the user, this may allow remote code execution and full read and write access to the whole XWiki installation. This has been patched in XWiki 14.10.12 and 15.5-rc-1 by adding appropriate escaping. The vulnerable template file `createinline.vm` is part of XWiki's WAR and can be patched by manually applying the changes from the fix.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2023-45136?

4 open source packages ship an affected version, including org.xwiki.platform:xwiki-platform-web-templates. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.xwiki.platform:xwiki-platform-web-templates` | Maven | From 12.0-rc-1 | 14.10.12 |
| `org.xwiki.platform:xwiki-platform-web-templates` | Maven | From 12.0-rc-1 | 14.10.12 |
| `org.xwiki.platform:xwiki-platform-web-templates` | Maven | From 15.0-rc-1 | 15.5-rc-1 |
| `org.xwiki.platform:xwiki-platform-web-templates` | Maven | From 15.0-rc-1 | 15.5-rc-1 |

Products: Xwiki Xwiki.

## How do I fix CVE-2023-45136?

Upgrade org.xwiki.platform:xwiki-platform-web-templates to a fixed version for your release line: 14.10.12 or 15.5-rc-1.

## Is CVE-2023-45136 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-45136 exists.

Public exploit code:

- XWiki < 14.10.14 - Cross-Site Scripting (nuclei): http/cves/2023/CVE-2023-45136.yaml

## Other vulnerabilities in Xwiki Xwiki

- [CVE-2025-24893](https://insights.sbomify.com/CVE-2025-24893/): XWiki Platform Eval Injection (critical 9.8, exploited in the wild)
- [CVE-2025-53836](https://insights.sbomify.com/CVE-2025-53836/): XWiki Rendering is vulnerable to RCE attacks when processing nested macros (critical 10.0)
- [CVE-2024-55662](https://insights.sbomify.com/CVE-2024-55662/): XWiki allows remote code execution through the extension sheet (critical 10.0)
- [CVE-2024-55877](https://insights.sbomify.com/CVE-2024-55877/): XWiki allows remote code execution from account through macro descriptions and XWiki.XWikiSyntaxMacrosList (critical 10.0)
- [CVE-2024-37901](https://insights.sbomify.com/CVE-2024-37901/): XWiki Platform vulnerable to remote code execution from account via SearchSuggestConfigSheet (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-45136 and fix it if it is affected.

What it is: CVE-2023-45136 is a critical cross-site scripting vulnerability in Xwiki Xwiki, published on 25 Oct 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-45136 exists.

Affected packages and fixed versions:
- org.xwiki.platform:xwiki-platform-web-templates (Maven): affected from 12.0-rc-1; fixed in 14.10.12
- org.xwiki.platform:xwiki-platform-web-templates (Maven): affected from 12.0-rc-1; fixed in 14.10.12
- org.xwiki.platform:xwiki-platform-web-templates (Maven): affected from 15.0-rc-1; fixed in 15.5-rc-1
- org.xwiki.platform:xwiki-platform-web-templates (Maven): affected from 15.0-rc-1; fixed in 15.5-rc-1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-45136/ (Markdown: https://insights.sbomify.com/CVE-2023-45136/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-45136
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-45136
- OSV: https://osv.dev/vulnerability/CVE-2023-45136

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-45136/
Summaries are generated and may contain mistakes; the official description above is the record.
