CVE-2023-45137 XWiki Platform XSS with edit right in the create document form for existing pages

Critical 9.1 Published Updated

Attackers can inject malicious scripts via document names in XWiki's create form, potentially executing code in victim browsers.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2023-45137?

CVE-2023-45137 is a critical cross-site scripting vulnerability in Xwiki Xwiki, published on 25 Oct 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

Official description

XWiki Platform is a generic wiki platform offering runtime services for applications built on top of it. `org.xwiki.platform:xwiki-platform-web` starting in version 3.1-milestone-2 and prior to version 13.4-rc-1, as well as `org.xwiki.platform:xwiki-platform-web-templates` prior to versions 14.10.12 and 15.5-rc-1, are vulnerable to cross-site scripting. When trying to create a document that already exists, XWiki displays an error message in the form for creating it. Due to missing escaping, this error message is vulnerable to raw HTML injection and thus XSS. The injected code is the document reference of the existing document so this requires that the attacker first creates a non-empty document whose name contains the attack code. This has been patched in `org.xwiki.platform:xwiki-platform-web` version 13.4-rc-1 and `org.xwiki.platform:xwiki-platform-web-templates` versions 14.10.12 and 15.5-rc-1 by adding the appropriate escaping. The vulnerable template file `createinline.vm` is part of XWiki's WAR and can be patched by manually applying the changes from the fix.

Weakness: CWE-79

Which versions are affected by CVE-2023-45137?

6 open source packages ship an affected version, including org.xwiki.platform:xwiki-platform-web-templates and org.xwiki.platform:xwiki-platform-web. It affects 1 product.

PackageAffectedFixed in
org.xwiki.platform:xwiki-platform-web-templates MavenAll versions14.10.12
org.xwiki.platform:xwiki-platform-web-templates MavenAll versions14.10.12
org.xwiki.platform:xwiki-platform-web-templates MavenFrom 15.0-rc-115.5-rc-1
org.xwiki.platform:xwiki-platform-web-templates MavenFrom 15.0-rc-115.5-rc-1
org.xwiki.platform:xwiki-platform-web MavenFrom 3.1-milestone-213.4-rc-1
org.xwiki.platform:xwiki-platform-web MavenFrom 3.1-milestone-213.4-rc-1

Products include Xwiki Xwiki.

How do I fix CVE-2023-45137?

Upgrade org.xwiki.platform:xwiki-platform-web-templates to a fixed version for your release line: 14.10.12 or 15.5-rc-1.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2023-45137 being exploited?

There is no known exploitation of CVE-2023-45137 in the wild and no public exploit code.

All Xwiki Xwiki vulnerabilities

Sources

Also known as GHSA-93gh-jgjj-r929.

Is CVE-2023-45137 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free