# CVE-2023-45138: Change Request Application vulnerable to XSS and remote code execution through change request title

> Attackers can inject scripts and execute remote code via change request titles in XWiki Change Request application, affecting users without special rights.

- **Severity:** Critical 10.0 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 12 Oct 2023
- **Updated:** 18 Sep 2024
- **Also known as:** GHSA-f776-w9v2-7vfj

## What is CVE-2023-45138?

CVE-2023-45138 is a critical cross-site scripting vulnerability in xwiki-contrib application-changerequest, published on 12 Oct 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Change Request is an pplication allowing users to request changes on a wiki without publishing the changes directly. Starting in version 0.11 and prior to version 1.9.2, it's possible for a user without any specific right to perform script injection and remote code execution just by inserting an appropriate title when creating a new Change Request. This vulnerability is particularly critical as Change Request aims at being created by user without any particular rights. The vulnerability has been fixed in Change Request 1.9.2. It's possible to workaround the issue without upgrading by editing the document `ChangeRequest.Code.ChangeRequestSheet` and by performing the same change as in the fix commit.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2023-45138?

2 open source packages ship an affected version, including org.xwiki.contrib.changerequest:application-changerequest-ui. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.xwiki.contrib.changerequest:application-changerequest-ui` | Maven | From 0.11 | 1.9.2 |
| `org.xwiki.contrib.changerequest:application-changerequest-ui` | Maven | From 0.11 | 1.9.2 |

Products: Xwiki Change Request.

## How do I fix CVE-2023-45138?

Upgrade org.xwiki.contrib.changerequest:application-changerequest-ui to 1.9.2 or later.

## Is CVE-2023-45138 being exploited?

There is no known exploitation of CVE-2023-45138 in the wild and no public exploit code.

## Other vulnerabilities in xwiki-contrib application-changerequest

- [CVE-2023-49280](https://insights.sbomify.com/CVE-2023-49280/): Data leak of password hash through xwiki change request (high 7.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-45138 and fix it if it is affected.

What it is: CVE-2023-45138 is a critical cross-site scripting vulnerability in xwiki-contrib application-changerequest, published on 12 Oct 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-45138 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.xwiki.contrib.changerequest:application-changerequest-ui (Maven): affected from 0.11; fixed in 1.9.2
- org.xwiki.contrib.changerequest:application-changerequest-ui (Maven): affected from 0.11; fixed in 1.9.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-45138/ (Markdown: https://insights.sbomify.com/CVE-2023-45138/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-45138
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-45138
- OSV: https://osv.dev/vulnerability/CVE-2023-45138

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-45138/
Summaries are generated and may contain mistakes; the official description above is the record.
