{"answers":{"affected":"3 open source packages ship an affected version, including fonttools. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-45139 exists.","fix":"Upgrade fonttools to 4.43.0 or later.","what":"CVE-2023-45139 is a high-severity vulnerability in fonttools, published on 10 Jan 2024."},"fix_prompt":"Check this codebase for CVE-2023-45139 and fix it if it is affected.\n\nWhat it is: CVE-2023-45139 is a high-severity vulnerability in fonttools, published on 10 Jan 2024. \nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-45139 exists.\n\nAffected packages and fixed versions:\n- fonttools (PyPI): affected from 4.28.2; fixed in 4.43.0\n- fonttools (PyPI): affected from 4.28.2; fixed in 4.43.0\n- fonttools (PyPI): affected from 4.28.2; fixed in 4.43.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-45139/ (Markdown: https://insights.sbomify.com/CVE-2023-45139/index.md)","id":"CVE-2023-45139","markdown":"https://insights.sbomify.com/CVE-2023-45139/index.md","name":"CVE-2023-45139","record":{"aliases":["DEBIAN-CVE-2023-45139","GHSA-6673-4983-2vx5","MGASA-2024-0060","OESA-2024-1080","PYSEC-2026-1388","UBUNTU-CVE-2023-45139","openSUSE-SU-2024:13686-1","openSUSE-SU-2026:11991-1"],"analysis":null,"analysis_generated_by":null,"assigner":"GitHub_M","cpe":[{"product":"fonttools","vendor":"fonttools"}],"cvss":{"score":7.5,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-611","name":"Improper Restriction of XML External Entity Reference"}],"description":"fontTools is a library for manipulating fonts, written in Python. The subsetting module has a XML External Entity Injection (XXE) vulnerability which allows an attacker to resolve arbitrary entities when a candidate font (OT-SVG fonts), which contains a SVG table, is parsed. This allows attackers to include arbitrary files from the filesystem fontTools is running on or make web requests from the host system. This vulnerability has been patched in version 4.43.0.","ecosystems":["PyPI","openSUSE:Tumbleweed"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"fonttools XML External Entity Injection (XXE) Vulnerability","id":"CVE-2023-45139","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":null,"year":"2023"},"n_packages":4,"n_references":6,"next":{"headline":"Group-based JIT MFA bypass on scp and sftp in The Bastion","id":"CVE-2023-45140"},"packages":[{"ecosystem":"PyPI","fixed":["4.43.0"],"introduced":["4.28.2"],"last_affected":[],"package":"fonttools","purl":null,"source":"GHSA-6673-4983-2vx5"},{"ecosystem":"PyPI","fixed":["4.43.0"],"introduced":["4.28.2"],"last_affected":[],"package":"fonttools","purl":"pkg:pypi/fonttools","source":"GHSA-6673-4983-2vx5"},{"ecosystem":"PyPI","fixed":["4.43.0"],"introduced":["4.28.2"],"last_affected":[],"package":"fonttools","purl":"pkg:pypi/fonttools","source":"PYSEC-2026-1388"},{"ecosystem":"openSUSE:Tumbleweed","fixed":["4.62.1-1.3"],"introduced":["0"],"last_affected":[],"package":"python-FontTools","purl":"pkg:rpm/opensuse/python-FontTools\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2026:11991-1"}],"prev":{"headline":"Change Request Application vulnerable to XSS and remote code execution through change request title","id":"CVE-2023-45138"},"products":["fonttools"],"published":"2024-01-10","related":[{"cvss_score":6.3,"headline":"fontTools is Vulnerable to Arbitrary File Write and XML injection in fontTools.varLib","id":"CVE-2025-66034","kev_date_added":null,"published":"2025-11-29"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-06-03","vendors":["fonttools"]},"summary":null,"url":"https://insights.sbomify.com/CVE-2023-45139/"}