# CVE-2023-45139: fonttools XML External Entity Injection (XXE) Vulnerability


- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 10 Jan 2024
- **Updated:** 3 Jun 2025
- **Also known as:** DEBIAN-CVE-2023-45139, GHSA-6673-4983-2vx5, MGASA-2024-0060, OESA-2024-1080, PYSEC-2026-1388, UBUNTU-CVE-2023-45139, openSUSE-SU-2024:13686-1, openSUSE-SU-2026:11991-1

## What is CVE-2023-45139?

CVE-2023-45139 is a high-severity vulnerability in fonttools, published on 10 Jan 2024. 

### Official description

fontTools is a library for manipulating fonts, written in Python. The subsetting module has a XML External Entity Injection (XXE) vulnerability which allows an attacker to resolve arbitrary entities when a candidate font (OT-SVG fonts), which contains a SVG table, is parsed. This allows attackers to include arbitrary files from the filesystem fontTools is running on or make web requests from the host system. This vulnerability has been patched in version 4.43.0.

Weakness: CWE-611 (Improper Restriction of XML External Entity Reference)

## Which versions are affected by CVE-2023-45139?

3 open source packages ship an affected version, including fonttools. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `fonttools` | PyPI | From 4.28.2 | 4.43.0 |
| `fonttools` | PyPI | From 4.28.2 | 4.43.0 |
| `fonttools` | PyPI | From 4.28.2 | 4.43.0 |
| `python-FontTools` | openSUSE:Tumbleweed | All versions | 4.62.1-1.3 |

Products: Fonttools Fonttools.

## How do I fix CVE-2023-45139?

Upgrade fonttools to 4.43.0 or later.

## Is CVE-2023-45139 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-45139 exists.

## Other vulnerabilities in fonttools

- [CVE-2025-66034](https://insights.sbomify.com/CVE-2025-66034/): fontTools is Vulnerable to Arbitrary File Write and XML injection in fontTools.varLib (medium 6.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-45139 and fix it if it is affected.

What it is: CVE-2023-45139 is a high-severity vulnerability in fonttools, published on 10 Jan 2024. 
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-45139 exists.

Affected packages and fixed versions:
- fonttools (PyPI): affected from 4.28.2; fixed in 4.43.0
- fonttools (PyPI): affected from 4.28.2; fixed in 4.43.0
- fonttools (PyPI): affected from 4.28.2; fixed in 4.43.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-45139/ (Markdown: https://insights.sbomify.com/CVE-2023-45139/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-45139
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-45139
- OSV: https://osv.dev/vulnerability/CVE-2023-45139

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-45139/
Summaries are generated and may contain mistakes; the official description above is the record.
