# CVE-2023-45141: CSRF Token Validation Vulnerability in fiber

> Attackers can forge malicious requests on behalf of users due to improper CSRF token validation in the Fiber Go web framework.

- **Severity:** High 8.6 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:H/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 16 Oct 2023
- **Updated:** 16 Sep 2024
- **Also known as:** GHSA-mv73-f69x-444p, GO-2023-2116

## What is CVE-2023-45141?

CVE-2023-45141 is a high-severity vulnerability in gofiber fiber, published on 16 Oct 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Fiber is an express inspired web framework written in Go. A Cross-Site Request Forgery (CSRF) vulnerability has been identified in the application, which allows an attacker to obtain tokens and forge malicious requests on behalf of a user. This can lead to unauthorized actions being taken on the user's behalf, potentially compromising the security and integrity of the application. The vulnerability is caused by improper validation and enforcement of CSRF tokens within the application. This vulnerability has been addressed in version 2.50.0 and users are advised to upgrade. Users should take additional security measures like captchas or Two-Factor Authentication (2FA) and set Session cookies with SameSite=Lax or SameSite=Secure, and the Secure and HttpOnly attributes.

Weakness: CWE-565 (Reliance on Cookies without Validation and Integrity Checking), CWE-352 (Cross-Site Request Forgery)

## Which versions are affected by CVE-2023-45141?

3 open source packages ship an affected version, including github.com/gofiber/fiber/v2. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/gofiber/fiber/v2` | Go | All versions | 2.50.0 |
| `github.com/gofiber/fiber/v2` | Go | All versions | 2.50.0 |
| `github.com/gofiber/fiber/v2` | Go | All versions | 2.50.0 |

Products: Gofiber Fiber.

## How do I fix CVE-2023-45141?

Upgrade github.com/gofiber/fiber/v2 to 2.50.0 or later.

## Is CVE-2023-45141 being exploited?

There is no known exploitation of CVE-2023-45141 in the wild and no public exploit code.

## Other vulnerabilities in gofiber fiber

- [CVE-2024-38513](https://insights.sbomify.com/CVE-2024-38513/): Fiber Session Middleware Token Injection Vulnerability (critical 10.0)
- [CVE-2023-45128](https://insights.sbomify.com/CVE-2023-45128/): CSRF Token Reuse Vulnerability in fiber (critical 10.0)
- [CVE-2024-25124](https://insights.sbomify.com/CVE-2024-25124/): Fiber has Insecure CORS Configuration, Allowing Wildcard Origin with Credentials (critical 9.4)
- [CVE-2025-66630](https://insights.sbomify.com/CVE-2025-66630/): Fiber insecurely fallsback in utils.UUIDv4() / utils.UUID() — predictable / zero‑UUID on crypto/rand failure (critical 9.2)
- [CVE-2025-54801](https://insights.sbomify.com/CVE-2025-54801/): Fiber Susceptible to Crash via `BodyParser` Due to Unvalidated Large Slice Index in Decoder (high 8.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-45141 and fix it if it is affected.

What it is: CVE-2023-45141 is a high-severity vulnerability in gofiber fiber, published on 16 Oct 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-45141 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/gofiber/fiber/v2 (Go): affected all versions; fixed in 2.50.0
- github.com/gofiber/fiber/v2 (Go): affected all versions; fixed in 2.50.0
- github.com/gofiber/fiber/v2 (Go): affected all versions; fixed in 2.50.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-45141/ (Markdown: https://insights.sbomify.com/CVE-2023-45141/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-45141
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-45141
- OSV: https://osv.dev/vulnerability/CVE-2023-45141

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-45141/
Summaries are generated and may contain mistakes; the official description above is the record.
