# CVE-2023-45143: Undici's cookie header not cleared on cross-origin redirect in fetch

> Undici fails to clear Cookie headers on cross-origin redirects, potentially leaking sensitive cookies to third-party sites or attackers controlling redirect targets.

- **Severity:** Low 3.9 (`CVSS:3.1/AV:N/AC:H/PR:H/UI:R/S:U/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 12 Oct 2023
- **Updated:** 13 Feb 2025
- **Also known as:** ALPINE-CVE-2023-45143, AZL-31338, CLEANSTART-2026-QW98383, CLEANSTART-2026-TM79261, CLEANSTART-2026-ZI83598, CLSA-2026-1775220180, DEBIAN-CVE-2023-45143, GHSA-wqq4-5wpv-mx2g, UBUNTU-CVE-2023-45143

## What is CVE-2023-45143?

CVE-2023-45143 is a low-severity vulnerability in Fedoraproject Fedora, published on 12 Oct 2023. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

### Official description

Undici is an HTTP/1.1 client written from scratch for Node.js. Prior to version 5.26.2, Undici already cleared Authorization headers on cross-origin redirects, but did not clear `Cookie` headers. By design, `cookie` headers are forbidden request headers, disallowing them to be set in RequestInit.headers in browser environments. Since undici handles headers more liberally than the spec, there was a disconnect from the assumptions the spec made, and undici's implementation of fetch. As such this may lead to accidental leakage of cookie to a third-party site or a malicious attacker who can control the redirection target (ie. an open redirector) to leak the cookie to the third party site. This was patched in version 5.26.2. There are no known workarounds.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2023-45143?

2 open source packages ship an affected version, including undici. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `undici` | npm | All versions | 5.26.2 |
| `undici` | npm | All versions | 5.26.2 |

Products: Fedoraproject Fedora, Nodejs Undici.

## How do I fix CVE-2023-45143?

Upgrade undici to 5.26.2 or later.

## Is CVE-2023-45143 being exploited?

There is no known exploitation of CVE-2023-45143 in the wild and no public exploit code.

## Other vulnerabilities in Fedoraproject Fedora

- [CVE-2024-4577](https://insights.sbomify.com/CVE-2024-4577/): PHP-CGI OS Command Injection (critical 9.8, exploited in the wild)
- [CVE-2021-39226](https://insights.sbomify.com/CVE-2021-39226/): Grafana Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2019-5544](https://insights.sbomify.com/CVE-2019-5544/): VMware ESXi and Horizon DaaS OpenSLP Heap-Based Buffer Overflow (critical 9.8, exploited in the wild)
- [CVE-2024-4947](https://insights.sbomify.com/CVE-2024-4947/): Google Chromium V8 Type Confusion (critical 9.6, exploited in the wild)
- [CVE-2024-4671](https://insights.sbomify.com/CVE-2024-4671/): Google Chromium Visuals Use-After-Free (critical 9.6, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-45143 and fix it if it is affected.

What it is: CVE-2023-45143 is a low-severity vulnerability in Fedoraproject Fedora, published on 12 Oct 2023. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2023-45143 in the wild and no public exploit code.

Affected packages and fixed versions:
- undici (npm): affected all versions; fixed in 5.26.2
- undici (npm): affected all versions; fixed in 5.26.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-45143/ (Markdown: https://insights.sbomify.com/CVE-2023-45143/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-45143
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-45143
- OSV: https://osv.dev/vulnerability/CVE-2023-45143

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-45143/
Summaries are generated and may contain mistakes; the official description above is the record.
