{"answers":{"affected":"2 open source packages ship an affected version, including com.xwiki.identity-oauth:identity-oauth-ui. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-45144 exists.","fix":"Upgrade com.xwiki.identity-oauth:identity-oauth-ui to 1.6 or later.","what":"CVE-2023-45144 is a critical code injection vulnerability in xwikisas identity-oauth, published on 16 Oct 2023. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2023-45144 and fix it if it is affected.\n\nWhat it is: CVE-2023-45144 is a critical code injection vulnerability in xwikisas identity-oauth, published on 16 Oct 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-45144 exists.\n\nAffected packages and fixed versions:\n- com.xwiki.identity-oauth:identity-oauth-ui (Maven): affected from 1.0; fixed in 1.6\n- com.xwiki.identity-oauth:identity-oauth-ui (Maven): affected from 1.0; fixed in 1.6\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-45144/ (Markdown: https://insights.sbomify.com/CVE-2023-45144/index.md)","id":"CVE-2023-45144","markdown":"https://insights.sbomify.com/CVE-2023-45144/index.md","name":"CVE-2023-45144","record":{"aliases":["GHSA-h2rm-29ch-wfmh"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"XWiki OAuth plugin","requires_auth":"none","summary":"Attackers can achieve remote code execution via syntax injection in the OAuth login screen, compromising the entire XWiki installation.","user_interaction":"not_required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"oauth_identity","vendor":"xwiki"}],"cvss":{"score":10,"severity":"critical","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-94","name":"Improper Control of Generation of Code"},{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"com.xwiki.identity-oauth:identity-oauth-ui is a package to aid in building identity and service providers based on OAuth authorizations. When a user logs in via the OAuth method, the identityOAuth parameters sent in the GET request is vulnerable to cross site scripting (XSS) and XWiki syntax injection. This allows remote code execution via the groovy macro and thus affects the confidentiality, integrity and availability of the whole XWiki installation. The issue has been fixed in Identity OAuth version 1.6. There are no known workarounds for this vulnerability and users are advised to upgrade.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Remote code execution from login screen through unescaped URL parameter in OAuth Identity XWiki App","id":"CVE-2023-45144","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"code_injection","year":"2023"},"n_packages":2,"n_references":5,"next":{"headline":"Redis Unix-domain socket may have be exposed with the wrong permissions for a short time window.","id":"CVE-2023-45145"},"packages":[{"ecosystem":"Maven","fixed":["1.6"],"introduced":["1.0"],"last_affected":[],"package":"com.xwiki.identity-oauth:identity-oauth-ui","purl":null,"source":"GHSA-h2rm-29ch-wfmh"},{"ecosystem":"Maven","fixed":["1.6"],"introduced":["1.0"],"last_affected":[],"package":"com.xwiki.identity-oauth:identity-oauth-ui","purl":"pkg:maven/com.xwiki.identity-oauth/identity-oauth-ui","source":"GHSA-h2rm-29ch-wfmh"}],"prev":{"headline":"Undici's cookie header not cleared on cross-origin redirect in fetch","id":"CVE-2023-45143"},"products":["identity-oauth"],"published":"2023-10-16","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-09-16","vendors":["xwikisas"]},"summary":"Attackers can achieve remote code execution via syntax injection in the OAuth login screen, compromising the entire XWiki installation.","url":"https://insights.sbomify.com/CVE-2023-45144/"}