# CVE-2023-45147: Arbitrary keys can be added to a topic's custom fields by any user in Discourse

> Users can add arbitrary custom fields to topics, potentially impacting plugin functionality if specific plugins are installed.

- **Severity:** Medium 4.9 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 16 Oct 2023
- **Updated:** 13 Sep 2024
- **Also known as:** BIT-discourse-2023-45147, GHSA-wm89-m359-f9qv

## What is CVE-2023-45147?

CVE-2023-45147 is a medium-severity missing authorization vulnerability in Discourse Discourse, published on 16 Oct 2023. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Discourse is an open source community platform. In affected versions any user can create a topic and add arbitrary custom fields to a topic. The severity of this vulnerability depends on what plugins are installed and how the plugins uses topic custom fields. For a default Discourse installation with the default plugins, this vulnerability has no impact. The problem has been patched in the latest version of Discourse. Users are advised to update to version 3.1.1 if they are on the stable branch or 3.2.0.beta2 if they are on the beta branch. Users unable to upgrade should disable any plugins that access topic custom fields.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2023-45147?

1 open source package ship an affected version, including discourse. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `discourse` | Bitnami | All versions to 3.1.1 | None |

Products: Discourse Discourse.

## How do I fix CVE-2023-45147?

No fix has been published for CVE-2023-45147 yet. Limit exposure of the affected software until one is available.

## Is CVE-2023-45147 being exploited?

There is no known exploitation of CVE-2023-45147 in the wild and no public exploit code.

## Other vulnerabilities in Discourse Discourse

- [CVE-2021-41163](https://insights.sbomify.com/CVE-2021-41163/): RCE via malicious SNS subscription payload (critical 10.0)
- [CVE-2022-36066](https://insights.sbomify.com/CVE-2022-36066/): Discourse vulnerable to RCE via admins uploading maliciously zipped file (critical 9.1)
- [CVE-2022-39356](https://insights.sbomify.com/CVE-2022-39356/): Discourse user account takeover via email and invite link (high 8.9)
- [CVE-2023-22468](https://insights.sbomify.com/CVE-2023-22468/): Discourse vulnerable to Cross-site Scripting in local oneboxes (high 8.8)
- [CVE-2026-27934](https://insights.sbomify.com/CVE-2026-27934/): Discourse leaks private topic title and post excerpt via user action API endpoint (high 8.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-45147 and fix it if it is affected.

What it is: CVE-2023-45147 is a medium-severity missing authorization vulnerability in Discourse Discourse, published on 16 Oct 2023. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-45147 in the wild and no public exploit code.

Affected packages and fixed versions:
- discourse (Bitnami): affected all versions up to 3.1.1; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-45147/ (Markdown: https://insights.sbomify.com/CVE-2023-45147/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-45147
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-45147
- OSV: https://osv.dev/vulnerability/CVE-2023-45147

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-45147/
Summaries are generated and may contain mistakes; the official description above is the record.
