CVE-2023-45160 Elevated Temp Directory Execution in 1E Client
An ordinary user can execute arbitrary code by replacing temporary instruction resource files with malicious scripts in the 1E Client.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- None listed
What is CVE-2023-45160?
CVE-2023-45160 is a high-severity code injection vulnerability in 1E Client, published on 5 Oct 2023. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
In the affected version of the 1E Client, an ordinary user could subvert downloaded instruction resource files, e.g., to substitute a harmful script. by replacing a resource script file created by an instruction at run time with a malicious script. The 1E Client's temporary directory is now locked down in the released patch.
Resolution: This has been fixed in patch Q23094
This issue has also been fixed in the Mac Client in updated versions of Non-Windows release v8.1.2.62 - please re-download from the 1E Support site.
Customers with Mac Client versions higher than v8.1 will need to upgrade to v23.11 to remediate this vulnerability.
Weakness: CWE-552
Which versions are affected by CVE-2023-45160?
It affects 1 product.
Products include 1e Client.
How do I fix CVE-2023-45160?
No fix has been published for CVE-2023-45160 yet. Limit exposure of the affected software until one is available.
Upgrade, and never evaluate templates, expressions or code built from user input. More about Code injection.
Is CVE-2023-45160 being exploited?
There is no known exploitation of CVE-2023-45160 in the wild and no public exploit code.
Other vulnerabilities in 1E Client
Sources
Also known as GHSA-v69j-q2rv-25rq.