CVE-2023-45277 Yamcs Path Traversal vulnerability

High 7.5 Published Updated

An attacker can exploit a directory traversal flaw in Yamcs to escape the base directory and read arbitrary files on the system.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2023-45277?

CVE-2023-45277 is a high-severity path traversal vulnerability in n/a, published on 19 Oct 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Yamcs 5.8.6 is vulnerable to directory traversal (issue 1 of 2). The vulnerability is in the storage functionality of the API and allows one to escape the base directory of the buckets, freely navigate system directories, and read arbitrary files.

Weakness: CWE-22

Which versions are affected by CVE-2023-45277?

2 open source packages ship an affected version, including org.yamcs:yamcs. It affects 1 product.

PackageAffectedFixed in
org.yamcs:yamcs MavenAll versions5.8.7
org.yamcs:yamcs MavenAll versions5.8.7

Products include Spaceapplications Yamcs.

How do I fix CVE-2023-45277?

Upgrade org.yamcs:yamcs to 5.8.7 or later.

Upgrade, and resolve every user-supplied path against an allowed base folder before opening it. More about Path traversal.

Is CVE-2023-45277 being exploited?

There is no known exploitation of CVE-2023-45277 in the wild and no public exploit code.

Public exploit code: 1 proofs of concept on GitHub.

Sources

Also known as GHSA-w4m2-qmh3-2g8f.

Is CVE-2023-45277 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free