{"answers":{"affected":"2 open source packages ship an affected version, including org.yamcs:yamcs. It affects 1 product.","exploited":"There is no known exploitation of CVE-2023-45277 in the wild and no public exploit code.","fix":"Upgrade org.yamcs:yamcs to 5.8.7 or later.","what":"CVE-2023-45277 is a high-severity path traversal vulnerability in n/a, published on 19 Oct 2023. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2023-45277 and fix it if it is affected.\n\nWhat it is: CVE-2023-45277 is a high-severity path traversal vulnerability in n/a, published on 19 Oct 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2023-45277 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.yamcs:yamcs (Maven): affected all versions; fixed in 5.8.7\n- org.yamcs:yamcs (Maven): affected all versions; fixed in 5.8.7\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-45277/ (Markdown: https://insights.sbomify.com/CVE-2023-45277/index.md)","id":"CVE-2023-45277","markdown":"https://insights.sbomify.com/CVE-2023-45277/index.md","name":"CVE-2023-45277","record":{"aliases":["GHSA-w4m2-qmh3-2g8f"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"Yamcs mission control","requires_auth":"none","summary":"An attacker can exploit a directory traversal flaw in Yamcs to escape the base directory and read arbitrary files on the system.","user_interaction":"not_required","vuln_class":"path_traversal"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"yamcs","vendor":"spaceapplications"}],"cvss":{"score":7.5,"severity":"high","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-22","name":"Improper Limitation of a Pathname to a Restricted Directory"}],"description":"Yamcs 5.8.6 is vulnerable to directory traversal (issue 1 of 2). The vulnerability is in the storage functionality of the API and allows one to escape the base directory of the buckets, freely navigate system directories, and read arbitrary files.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":"2025-08-17","github_poc":1,"max_poc_stars":0,"metasploit":0,"nuclei":0,"refs":[{"date":"2025-08-17T06:23:12Z","kind":"github_poc","ref":"https://github.com/shoucheng3/yamcs__yamcs_CVE-2023-45277_5-8-6","stars":0,"title":null}],"tier":"poc_unverified"},"has_fix":true,"headline":"Yamcs Path Traversal vulnerability","id":"CVE-2023-45277","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"path_traversal","year":"2023"},"n_packages":2,"n_references":2,"next":{"headline":"Yamcs API Directory Traversal vulnerability","id":"CVE-2023-45278"},"packages":[{"ecosystem":"Maven","fixed":["5.8.7"],"introduced":["0"],"last_affected":[],"package":"org.yamcs:yamcs","purl":null,"source":"GHSA-w4m2-qmh3-2g8f"},{"ecosystem":"Maven","fixed":["5.8.7"],"introduced":["0"],"last_affected":[],"package":"org.yamcs:yamcs","purl":"pkg:maven/org.yamcs/yamcs","source":"GHSA-w4m2-qmh3-2g8f"}],"prev":{"headline":"WordPress Automated Editor Plugin \u003c= 1.3 is vulnerable to Cross Site Request Forgery (CSRF)","id":"CVE-2023-45276"},"products":["n/a"],"published":"2023-10-19","related":[{"cvss_score":9.8,"headline":"Yamcs: Remote Code Execution via Mission Database algorithm override","id":"CVE-2026-46562","kev_date_added":null,"published":"2026-07-16"},{"cvss_score":9.1,"headline":"Yamcs: Server-Side Code Injection (RCE) via Janino Expression Engine in `JavaExprAlgorithmExecutionFactory`","id":"CVE-2026-44632","kev_date_added":null,"published":"2026-07-16"},{"cvss_score":9.1,"headline":"Yamcs: Authenticated Remote Code Execution (RCE) via Jython Algorithm Code Injection","id":"CVE-2026-46621","kev_date_added":null,"published":"2026-07-16"},{"cvss_score":9.1,"headline":"Yamcs API Directory Traversal vulnerability","id":"CVE-2023-45278","kev_date_added":null,"published":"2023-10-19"},{"cvss_score":6.5,"headline":"Yamcs: No Rate Limiting on Authentication Endpoint","id":"CVE-2026-44596","kev_date_added":null,"published":"2026-07-16"},{"cvss_score":6.1,"headline":"Cross-site scripting in n/a","id":"CVE-2023-45281","kev_date_added":null,"published":"2023-10-19"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"open","licence":"CC0","name":"PoC-in-GitHub"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-02","vendors":["n/a"]},"summary":"An attacker can exploit a directory traversal flaw in Yamcs to escape the base directory and read arbitrary files on the system.","url":"https://insights.sbomify.com/CVE-2023-45277/"}