# CVE-2023-45277: Yamcs Path Traversal vulnerability

> An attacker can exploit a directory traversal flaw in Yamcs to escape the base directory and read arbitrary files on the system.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 19 Oct 2023
- **Updated:** 2 Aug 2024
- **Also known as:** GHSA-w4m2-qmh3-2g8f

## What is CVE-2023-45277?

CVE-2023-45277 is a high-severity path traversal vulnerability in n/a, published on 19 Oct 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Yamcs 5.8.6 is vulnerable to directory traversal (issue 1 of 2). The vulnerability is in the storage functionality of the API and allows one to escape the base directory of the buckets, freely navigate system directories, and read arbitrary files.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2023-45277?

2 open source packages ship an affected version, including org.yamcs:yamcs. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.yamcs:yamcs` | Maven | All versions | 5.8.7 |
| `org.yamcs:yamcs` | Maven | All versions | 5.8.7 |

Products: Spaceapplications Yamcs.

## How do I fix CVE-2023-45277?

Upgrade org.yamcs:yamcs to 5.8.7 or later.

## Is CVE-2023-45277 being exploited?

There is no known exploitation of CVE-2023-45277 in the wild and no public exploit code.

Public exploit code:

- https://github.com/shoucheng3/yamcs__yamcs_CVE-2023-45277_5-8-6 (github_poc): https://github.com/shoucheng3/yamcs__yamcs_CVE-2023-45277_5-8-6

## Other vulnerabilities in n/a

- [CVE-2026-46562](https://insights.sbomify.com/CVE-2026-46562/): Yamcs: Remote Code Execution via Mission Database algorithm override (critical 9.8)
- [CVE-2026-44632](https://insights.sbomify.com/CVE-2026-44632/): Yamcs: Server-Side Code Injection (RCE) via Janino Expression Engine in `JavaExprAlgorithmExecutionFactory` (critical 9.1)
- [CVE-2026-46621](https://insights.sbomify.com/CVE-2026-46621/): Yamcs: Authenticated Remote Code Execution (RCE) via Jython Algorithm Code Injection (critical 9.1)
- [CVE-2023-45278](https://insights.sbomify.com/CVE-2023-45278/): Yamcs API Directory Traversal vulnerability (critical 9.1)
- [CVE-2026-44596](https://insights.sbomify.com/CVE-2026-44596/): Yamcs: No Rate Limiting on Authentication Endpoint (medium 6.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-45277 and fix it if it is affected.

What it is: CVE-2023-45277 is a high-severity path traversal vulnerability in n/a, published on 19 Oct 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-45277 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.yamcs:yamcs (Maven): affected all versions; fixed in 5.8.7
- org.yamcs:yamcs (Maven): affected all versions; fixed in 5.8.7

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-45277/ (Markdown: https://insights.sbomify.com/CVE-2023-45277/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-45277
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-45277
- OSV: https://osv.dev/vulnerability/CVE-2023-45277

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-45277/
Summaries are generated and may contain mistakes; the official description above is the record.
