{"answers":{"affected":"2 open source packages ship an affected version, including org.yamcs:yamcs. It affects 1 product.","exploited":"There is no known exploitation of CVE-2023-45278 in the wild and no public exploit code.","fix":"Upgrade org.yamcs:yamcs to 5.8.7 or later.","what":"CVE-2023-45278 is a critical path traversal vulnerability in n/a, published on 19 Oct 2023. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2023-45278 and fix it if it is affected.\n\nWhat it is: CVE-2023-45278 is a critical path traversal vulnerability in n/a, published on 19 Oct 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2023-45278 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.yamcs:yamcs (Maven): affected all versions; fixed in 5.8.7\n- org.yamcs:yamcs (Maven): affected all versions; fixed in 5.8.7\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-45278/ (Markdown: https://insights.sbomify.com/CVE-2023-45278/index.md)","id":"CVE-2023-45278","markdown":"https://insights.sbomify.com/CVE-2023-45278/index.md","name":"CVE-2023-45278","record":{"aliases":["GHSA-43fw-536j-w37j"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["data_modify"],"network_reachable":"yes","non_default_config":false,"product_category":"Yamcs mission control","requires_auth":"none","summary":"Attackers can delete arbitrary files via crafted HTTP DELETE requests in Yamcs storage API, requiring an upgrade to mitigate.","user_interaction":"not_required","vuln_class":"path_traversal"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"yamcs","vendor":"spaceapplications"}],"cvss":{"score":9.1,"severity":"critical","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-22","name":"Improper Limitation of a Pathname to a Restricted Directory"}],"description":"Directory Traversal vulnerability in the storage functionality of the API in Yamcs 5.8.6 allows attackers to delete arbitrary files via crafted HTTP DELETE request.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Yamcs API Directory Traversal vulnerability","id":"CVE-2023-45278","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"path_traversal","year":"2023"},"n_packages":2,"n_references":2,"next":{"headline":"Yamcs Cross-site Scripting vulnerability","id":"CVE-2023-45279"},"packages":[{"ecosystem":"Maven","fixed":["5.8.7"],"introduced":["0"],"last_affected":[],"package":"org.yamcs:yamcs","purl":null,"source":"GHSA-43fw-536j-w37j"},{"ecosystem":"Maven","fixed":["5.8.7"],"introduced":["0"],"last_affected":[],"package":"org.yamcs:yamcs","purl":"pkg:maven/org.yamcs/yamcs","source":"GHSA-43fw-536j-w37j"}],"prev":{"headline":"Yamcs Path Traversal vulnerability","id":"CVE-2023-45277"},"products":["n/a"],"published":"2023-10-19","related":[{"cvss_score":9.8,"headline":"Yamcs: Remote Code Execution via Mission Database algorithm override","id":"CVE-2026-46562","kev_date_added":null,"published":"2026-07-16"},{"cvss_score":9.1,"headline":"Yamcs: Server-Side Code Injection (RCE) via Janino Expression Engine in `JavaExprAlgorithmExecutionFactory`","id":"CVE-2026-44632","kev_date_added":null,"published":"2026-07-16"},{"cvss_score":9.1,"headline":"Yamcs: Authenticated Remote Code Execution (RCE) via Jython Algorithm Code Injection","id":"CVE-2026-46621","kev_date_added":null,"published":"2026-07-16"},{"cvss_score":7.5,"headline":"Yamcs Path Traversal vulnerability","id":"CVE-2023-45277","kev_date_added":null,"published":"2023-10-19"},{"cvss_score":6.5,"headline":"Yamcs: No Rate Limiting on Authentication Endpoint","id":"CVE-2026-44596","kev_date_added":null,"published":"2026-07-16"},{"cvss_score":6.1,"headline":"Cross-site scripting in n/a","id":"CVE-2023-45281","kev_date_added":null,"published":"2023-10-19"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-02","vendors":["n/a"]},"summary":"Attackers can delete arbitrary files via crafted HTTP DELETE requests in Yamcs storage API, requiring an upgrade to mitigate.","url":"https://insights.sbomify.com/CVE-2023-45278/"}