{"answers":{"affected":"2 open source packages ship an affected version, including org.yamcs:yamcs. It affects 1 product.","exploited":"There is no known exploitation of CVE-2023-45279 in the wild and no public exploit code.","fix":"Upgrade org.yamcs:yamcs to 5.8.7 or later.","what":"CVE-2023-45279 is a medium-severity cross-site scripting vulnerability in n/a, published on 19 Oct 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2023-45279 and fix it if it is affected.\n\nWhat it is: CVE-2023-45279 is a medium-severity cross-site scripting vulnerability in n/a, published on 19 Oct 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2023-45279 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.yamcs:yamcs (Maven): affected all versions; fixed in 5.8.7\n- org.yamcs:yamcs (Maven): affected all versions; fixed in 5.8.7\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-45279/ (Markdown: https://insights.sbomify.com/CVE-2023-45279/index.md)","id":"CVE-2023-45279","markdown":"https://insights.sbomify.com/CVE-2023-45279/index.md","name":"CVE-2023-45279","record":{"aliases":["GHSA-4cqv-q33x-wfxw"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Yamcs mission control","requires_auth":"low_privilege","summary":"An attacker can upload a malicious display file to Yamcs buckets, leading to cross-site scripting when the display is viewed by a user.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"yamcs","vendor":"spaceapplications"}],"cvss":{"score":5.4,"severity":"medium","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Yamcs 5.8.6 allows XSS (issue 1 of 2). It comes with a Bucket as its primary storage mechanism. Buckets allow for the upload of any file. There's a way to upload a display referencing a malicious JavaScript file to the bucket. The user can then open the uploaded display by selecting Telemetry from the menu and navigating to the display.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Yamcs Cross-site Scripting vulnerability","id":"CVE-2023-45279","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"xss","year":"2023"},"n_packages":2,"n_references":2,"next":{"headline":"Yamcs Cross-site Scripting vulnerability","id":"CVE-2023-45280"},"packages":[{"ecosystem":"Maven","fixed":["5.8.7"],"introduced":["0"],"last_affected":[],"package":"org.yamcs:yamcs","purl":null,"source":"GHSA-4cqv-q33x-wfxw"},{"ecosystem":"Maven","fixed":["5.8.7"],"introduced":["0"],"last_affected":[],"package":"org.yamcs:yamcs","purl":"pkg:maven/org.yamcs/yamcs","source":"GHSA-4cqv-q33x-wfxw"}],"prev":{"headline":"Yamcs API Directory Traversal vulnerability","id":"CVE-2023-45278"},"products":["n/a"],"published":"2023-10-19","related":[{"cvss_score":9.8,"headline":"Yamcs: Remote Code Execution via Mission Database algorithm override","id":"CVE-2026-46562","kev_date_added":null,"published":"2026-07-16"},{"cvss_score":9.1,"headline":"Yamcs: Server-Side Code Injection (RCE) via Janino Expression Engine in `JavaExprAlgorithmExecutionFactory`","id":"CVE-2026-44632","kev_date_added":null,"published":"2026-07-16"},{"cvss_score":9.1,"headline":"Yamcs: Authenticated Remote Code Execution (RCE) via Jython Algorithm Code Injection","id":"CVE-2026-46621","kev_date_added":null,"published":"2026-07-16"},{"cvss_score":9.1,"headline":"Yamcs API Directory Traversal vulnerability","id":"CVE-2023-45278","kev_date_added":null,"published":"2023-10-19"},{"cvss_score":7.5,"headline":"Yamcs Path Traversal vulnerability","id":"CVE-2023-45277","kev_date_added":null,"published":"2023-10-19"},{"cvss_score":6.5,"headline":"Yamcs: No Rate Limiting on Authentication Endpoint","id":"CVE-2026-44596","kev_date_added":null,"published":"2026-07-16"},{"cvss_score":6.1,"headline":"Cross-site scripting in n/a","id":"CVE-2023-45281","kev_date_added":null,"published":"2023-10-19"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-02","vendors":["n/a"]},"summary":"An attacker can upload a malicious display file to Yamcs buckets, leading to cross-site scripting when the display is viewed by a user.","url":"https://insights.sbomify.com/CVE-2023-45279/"}