# CVE-2023-45279: Yamcs Cross-site Scripting vulnerability

> An attacker can upload a malicious display file to Yamcs buckets, leading to cross-site scripting when the display is viewed by a user.

- **Severity:** Medium 5.4 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 19 Oct 2023
- **Updated:** 2 Aug 2024
- **Also known as:** GHSA-4cqv-q33x-wfxw

## What is CVE-2023-45279?

CVE-2023-45279 is a medium-severity cross-site scripting vulnerability in n/a, published on 19 Oct 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Yamcs 5.8.6 allows XSS (issue 1 of 2). It comes with a Bucket as its primary storage mechanism. Buckets allow for the upload of any file. There's a way to upload a display referencing a malicious JavaScript file to the bucket. The user can then open the uploaded display by selecting Telemetry from the menu and navigating to the display.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2023-45279?

2 open source packages ship an affected version, including org.yamcs:yamcs. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.yamcs:yamcs` | Maven | All versions | 5.8.7 |
| `org.yamcs:yamcs` | Maven | All versions | 5.8.7 |

Products: Spaceapplications Yamcs.

## How do I fix CVE-2023-45279?

Upgrade org.yamcs:yamcs to 5.8.7 or later.

## Is CVE-2023-45279 being exploited?

There is no known exploitation of CVE-2023-45279 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2026-46562](https://insights.sbomify.com/CVE-2026-46562/): Yamcs: Remote Code Execution via Mission Database algorithm override (critical 9.8)
- [CVE-2026-44632](https://insights.sbomify.com/CVE-2026-44632/): Yamcs: Server-Side Code Injection (RCE) via Janino Expression Engine in `JavaExprAlgorithmExecutionFactory` (critical 9.1)
- [CVE-2026-46621](https://insights.sbomify.com/CVE-2026-46621/): Yamcs: Authenticated Remote Code Execution (RCE) via Jython Algorithm Code Injection (critical 9.1)
- [CVE-2023-45278](https://insights.sbomify.com/CVE-2023-45278/): Yamcs API Directory Traversal vulnerability (critical 9.1)
- [CVE-2023-45277](https://insights.sbomify.com/CVE-2023-45277/): Yamcs Path Traversal vulnerability (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-45279 and fix it if it is affected.

What it is: CVE-2023-45279 is a medium-severity cross-site scripting vulnerability in n/a, published on 19 Oct 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2023-45279 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.yamcs:yamcs (Maven): affected all versions; fixed in 5.8.7
- org.yamcs:yamcs (Maven): affected all versions; fixed in 5.8.7

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-45279/ (Markdown: https://insights.sbomify.com/CVE-2023-45279/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-45279
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-45279
- OSV: https://osv.dev/vulnerability/CVE-2023-45279

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-45279/
Summaries are generated and may contain mistakes; the official description above is the record.
