# CVE-2023-45311: Code injection in fsevents

> An adversary could execute arbitrary code by controlling the external binary download URL used by the fsevents library.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 Oct 2023
- **Updated:** 26 Nov 2024
- **Also known as:** GHSA-8r6j-v8pm-fqw3, UBUNTU-CVE-2023-45311

## What is CVE-2023-45311?

CVE-2023-45311 is a critical vulnerability in n/a, published on 6 Oct 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

fsevents before 1.2.11 depends on the https://fsevents-binaries.s3-us-west-2.amazonaws.com URL, which might allow an adversary to execute arbitrary code if any JavaScript project (that depends on fsevents) distributes code that was obtained from that URL at a time when it was controlled by an adversary. NOTE: some sources feel that this means that no version is affected any longer, because the URL is not controlled by an adversary.

Weakness: CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2023-45311?

2 open source packages ship an affected version, including fsevents. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `fsevents` | npm | All versions | 1.2.11 |
| `fsevents` | npm | All versions | 1.2.11 |

Products: Fsevents Project Fsevents.

## How do I fix CVE-2023-45311?

Upgrade fsevents to 1.2.11 or later.

## Is CVE-2023-45311 being exploited?

There is no known exploitation of CVE-2023-45311 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-45311 and fix it if it is affected.

What it is: CVE-2023-45311 is a critical vulnerability in n/a, published on 6 Oct 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-45311 in the wild and no public exploit code.

Affected packages and fixed versions:
- fsevents (npm): affected all versions; fixed in 1.2.11
- fsevents (npm): affected all versions; fixed in 1.2.11

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-45311/ (Markdown: https://insights.sbomify.com/CVE-2023-45311/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-45311
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-45311
- OSV: https://osv.dev/vulnerability/CVE-2023-45311

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-45311/
Summaries are generated and may contain mistakes; the official description above is the record.
