CVE-2023-4532 Incorrect Authorization in GitLab
Users can link CI/CD jobs from private projects they do not have access to, potentially exposing sensitive pipeline information.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2023-4532?
CVE-2023-4532 is a medium-severity missing authorization vulnerability in Gitlab Gitlab, published on 29 Sep 2023. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
An issue has been discovered in GitLab affecting all versions starting from 16.2 before 16.2.8, all versions starting from 16.3 before 16.3.5, all versions starting from 16.4 before 16.4.1. Users were capable of linking CI/CD jobs of private projects which they are not a member of.
Weakness: CWE-863
Which versions are affected by CVE-2023-4532?
1 open source package ship an affected version, including gitlab. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
gitlab Bitnami | From 16.2.0 | 16.2.8, 16.3.5, 16.4.1 |
Products include Gitlab Gitlab.
How do I fix CVE-2023-4532?
Upgrade gitlab to a fixed version for your release line: 16.2.8, 16.3.5 or 16.4.1.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2023-4532 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-4532 exists.
Other vulnerabilities in Gitlab Gitlab
- CVE-2026-97229 GitLab Community Edition and Enterprise Edition Integer Overflow or Wraparound
- CVE-2026-85706 GitLab Community Edition and Enterprise Edition Path Traversal
- CVE-2023-7028 GitLab Community and Enterprise Editions Improper Access Control
- CVE-2021-22205 GitLab Community and Enterprise Editions Remote Code Execution
- CVE-2021-39935 GitLab Community and Enterprise Editions Server-Side Request Forgery (SSRF)
Sources
Also known as BIT-gitlab-2023-4532, GHSA-cpg4-gv23-mpmj, UBUNTU-CVE-2023-4532.