CVE-2023-45348 Apache Airflow: Configuration information leakage vulnerability

Medium 4.3 Published Updated

Authenticated users can leak sensitive configuration data in Apache Airflow if the expose_config option is set to non-sensitive-only.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2023-45348?

CVE-2023-45348 is a medium-severity vulnerability in Apache Airflow, published on 14 Oct 2023. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

Apache Airflow, versions 2.7.0 and 2.7.1, is affected by a vulnerability that allows an authenticated user to retrieve sensitive configuration information when the "expose_config" option is set to "non-sensitive-only". The `expose_config` option is False by default. It is recommended to upgrade to a version that is not affected.

Weakness: CWE-200

Which versions are affected by CVE-2023-45348?

4 open source packages ship an affected version, including apache-airflow and airflow. It affects 1 product.

PackageAffectedFixed in
apache-airflow PyPIFrom 2.7.02.7.2
apache-airflow PyPIFrom 2.7.02.7.2
apache-airflow PyPIFrom 2.7.02.7.2
airflow BitnamiFrom 2.7.02.7.2

Products include Apache Airflow.

How do I fix CVE-2023-45348?

Upgrade apache-airflow to 2.7.2 or later.

Is CVE-2023-45348 being exploited?

There is no known exploitation of CVE-2023-45348 in the wild and no public exploit code.

All Apache Airflow vulnerabilities

Sources

Also known as BIT-airflow-2023-45348, GHSA-fpxx-xv4c-gxqp, PYSEC-2023-204.

Is CVE-2023-45348 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free