CVE-2023-45360 Cross-site scripting in n/a
Cross-site scripting vulnerability in MediaWiki allows attackers to inject malicious scripts via new message notifications.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2023-45360?
CVE-2023-45360 is a medium-severity cross-site scripting vulnerability in Mediawiki Mediawiki, published on 3 Nov 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Official description
An issue was discovered in MediaWiki before 1.35.12, 1.36.x through 1.39.x before 1.39.5, and 1.40.x before 1.40.1. There is XSS in youhavenewmessagesmanyusers and youhavenewmessages i18n messages. This is related to MediaWiki:Youhavenewmessagesfromusers.
Weakness: CWE-79
Which versions are affected by CVE-2023-45360?
1 open source package ship an affected version, including mediawiki. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
mediawiki Bitnami | All versions | 1.35.12, 1.39.5, 1.40.1 |
Products include Mediawiki Mediawiki.
How do I fix CVE-2023-45360?
Upgrade mediawiki to a fixed version for your release line: 1.35.12, 1.39.5 or 1.40.1.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2023-45360 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-45360 exists.
Other vulnerabilities in Mediawiki Mediawiki
Sources
Also known as BIT-mediawiki-2023-45360, DEBIAN-CVE-2023-45360, GHSA-qpc2-222x-ppq9, UBUNTU-CVE-2023-45360.