CVE-2023-45363 MediaWiki Denial of Service vulnerability
Attackers can cause a denial of service via an unbounded loop in MediaWiki when specific redirect and title conversion options are enabled.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2023-45363?
CVE-2023-45363 is a high-severity denial of service vulnerability in Debian Debian Linux, published on 9 Oct 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
An issue was discovered in ApiPageSet.php in MediaWiki before 1.35.12, 1.36.x through 1.39.x before 1.39.5, and 1.40.x before 1.40.1. It allows attackers to cause a denial of service (unbounded loop and RequestTimeoutException) when querying pages redirected to other variants with redirects and converttitles set.
Weakness: CWE-835
Which versions are affected by CVE-2023-45363?
7 open source packages ship an affected version, including mediawiki/core and mediawiki. It affects 2 products.
| Package | Affected | Fixed in |
|---|---|---|
mediawiki/core Packagist | All versions | 1.35.12 |
mediawiki/core Packagist | All versions | 1.35.12 |
mediawiki/core Packagist | From 1.36.0 | 1.39.5 |
mediawiki/core Packagist | From 1.36.0 | 1.39.5 |
mediawiki/core Packagist | From 1.40.0 | 1.40.1 |
mediawiki/core Packagist | From 1.40.0 | 1.40.1 |
1 more packages
mediawiki Bitnami | All versions | 1.35.12, 1.39.5, 1.40.1 |
Products include Debian Debian Linux, Mediawiki Mediawiki.
How do I fix CVE-2023-45363?
Upgrade mediawiki/core to a fixed version for your release line: 1.35.12, 1.39.5 or 1.40.1.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2023-45363 being exploited?
There is no known exploitation of CVE-2023-45363 in the wild and no public exploit code.
Other vulnerabilities in Debian Debian Linux
Sources
Also known as BIT-mediawiki-2023-45363, DEBIAN-CVE-2023-45363, GHSA-w5fx-cx7f-6vr9, UBUNTU-CVE-2023-45363.