CVE-2023-45364 Information disclosure in n/a
Attackers can leak existence, timestamps, and IDs of deleted revisions in MediaWiki due to incorrect permission checks.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2023-45364?
CVE-2023-45364 is a medium-severity vulnerability in Debian Debian Linux, published on 9 Oct 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
An issue was discovered in includes/page/Article.php in MediaWiki 1.36.x through 1.39.x before 1.39.5 and 1.40.x before 1.40.1. Deleted revision existence is leaked due to incorrect permissions being checked. This reveals that a given revision ID belonged to the given page title, and its timestamp, both of which are not supposed to be public information.
Weakness: CWE-732
Which versions are affected by CVE-2023-45364?
1 open source package ship an affected version, including mediawiki. It affects 2 products.
| Package | Affected | Fixed in |
|---|---|---|
mediawiki Bitnami | From 1.36.0 | 1.39.5, 1.40.1 |
Products include Debian Debian Linux, Mediawiki Mediawiki.
How do I fix CVE-2023-45364?
Upgrade mediawiki to a fixed version for your release line: 1.39.5 or 1.40.1.
Is CVE-2023-45364 being exploited?
There is no known exploitation of CVE-2023-45364 in the wild and no public exploit code.
Other vulnerabilities in Debian Debian Linux
Sources
Also known as BIT-mediawiki-2023-45364, DEBIAN-CVE-2023-45364, GHSA-mjh3-fcq9-8g4h, UBUNTU-CVE-2023-45364.