# CVE-2023-45364: Information disclosure in n/a

> Attackers can leak existence, timestamps, and IDs of deleted revisions in MediaWiki due to incorrect permission checks.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 9 Oct 2023
- **Updated:** 19 Sep 2024
- **Also known as:** BIT-mediawiki-2023-45364, DEBIAN-CVE-2023-45364, GHSA-mjh3-fcq9-8g4h, UBUNTU-CVE-2023-45364

## What is CVE-2023-45364?

CVE-2023-45364 is a medium-severity vulnerability in Debian Debian Linux, published on 9 Oct 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

An issue was discovered in includes/page/Article.php in MediaWiki 1.36.x through 1.39.x before 1.39.5 and 1.40.x before 1.40.1. Deleted revision existence is leaked due to incorrect permissions being checked. This reveals that a given revision ID belonged to the given page title, and its timestamp, both of which are not supposed to be public information.

Weakness: CWE-732 (Incorrect Permission Assignment for Critical Resource)

## Which versions are affected by CVE-2023-45364?

1 open source package ship an affected version, including mediawiki. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mediawiki` | Bitnami | From 1.36.0 | 1.39.5, 1.40.1 |

Products: Debian Debian Linux, Mediawiki Mediawiki.

## How do I fix CVE-2023-45364?

Upgrade mediawiki to a fixed version for your release line: 1.39.5 or 1.40.1.

## Is CVE-2023-45364 being exploited?

There is no known exploitation of CVE-2023-45364 in the wild and no public exploit code.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-45364 and fix it if it is affected.

What it is: CVE-2023-45364 is a medium-severity vulnerability in Debian Debian Linux, published on 9 Oct 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-45364 in the wild and no public exploit code.

Affected packages and fixed versions:
- mediawiki (Bitnami): affected from 1.36.0; fixed in 1.39.5, 1.40.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-45364/ (Markdown: https://insights.sbomify.com/CVE-2023-45364/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-45364
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-45364
- OSV: https://osv.dev/vulnerability/CVE-2023-45364

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-45364/
Summaries are generated and may contain mistakes; the official description above is the record.
