CVE-2023-45367 Denial of service in n/a

Medium 6.5 Published Updated

An attacker can cause a denial of service by storing an arbitrary number of rows in the database via a specific CheckUser extension URL.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2023-45367?

CVE-2023-45367 is a medium-severity denial of service vulnerability in Mediawiki Mediawiki, published on 9 Oct 2023. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

An issue was discovered in the CheckUser extension for MediaWiki before 1.35.12, 1.36.x through 1.39.x before 1.39.5, and 1.40.x before 1.40.1. A user can use a rest.php/checkuser/v0/useragent-clienthints/revision/ URL to store an arbitrary number of rows in cu_useragent_clienthints, leading to a denial of service.

Which versions are affected by CVE-2023-45367?

1 open source package ship an affected version, including mediawiki. It affects 1 product.

PackageAffectedFixed in
mediawiki BitnamiAll versions1.35.12, 1.39.5, 1.40.1

Products include Mediawiki Mediawiki.

How do I fix CVE-2023-45367?

Upgrade mediawiki to a fixed version for your release line: 1.35.12, 1.39.5 or 1.40.1.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2023-45367 being exploited?

There is no known exploitation of CVE-2023-45367 in the wild and no public exploit code.

All Mediawiki Mediawiki vulnerabilities

Sources

Also known as BIT-mediawiki-2023-45367, GHSA-86q3-j68g-7jjc.

Is CVE-2023-45367 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free