CVE-2023-45371 Denial of service in n/a
Attackers can exhaust server resources by repeatedly merging items due to missing rate limits in the Wikibase extension.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2023-45371?
CVE-2023-45371 is a high-severity denial of service vulnerability in Mediawiki Mediawiki, published on 9 Oct 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
An issue was discovered in the Wikibase extension for MediaWiki before 1.35.12, 1.36.x through 1.39.x before 1.39.5, and 1.40.x before 1.40.1. There is no rate limit for merging items.
Weakness: CWE-770
Which versions are affected by CVE-2023-45371?
1 open source package ship an affected version, including mediawiki. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
mediawiki Bitnami | All versions | 1.35.12, 1.39.5, 1.40.1 |
Products include Mediawiki Mediawiki.
How do I fix CVE-2023-45371?
Upgrade mediawiki to a fixed version for your release line: 1.35.12, 1.39.5 or 1.40.1.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2023-45371 being exploited?
There is no known exploitation of CVE-2023-45371 in the wild and no public exploit code.
Other vulnerabilities in Mediawiki Mediawiki
Sources
Also known as BIT-mediawiki-2023-45371, GHSA-7g5q-3gqm-27gq.