# CVE-2023-45372: Security feature bypass in n/a

> Attackers can bypass edit filters during item merging in the Wikibase extension for MediaWiki, allowing unauthorized content changes.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 9 Oct 2023
- **Updated:** 19 Sep 2024
- **Also known as:** BIT-mediawiki-2023-45372, GHSA-2r79-m38c-p4mw

## What is CVE-2023-45372?

CVE-2023-45372 is a medium-severity vulnerability in Mediawiki Mediawiki, published on 9 Oct 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

An issue was discovered in the Wikibase extension for MediaWiki before 1.35.12, 1.36.x through 1.39.x before 1.39.5, and 1.40.x before 1.40.1. During item merging, ItemMergeInteractor does not have an edit filter running (e.g., AbuseFilter).

Weakness: CWE-693 (Protection Mechanism Failure)

## Which versions are affected by CVE-2023-45372?

1 open source package ship an affected version, including mediawiki. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mediawiki` | Bitnami | All versions | 1.35.12, 1.39.5, 1.40.1 |

Products: Mediawiki Mediawiki.

## How do I fix CVE-2023-45372?

Upgrade mediawiki to a fixed version for your release line: 1.35.12, 1.39.5 or 1.40.1.

## Is CVE-2023-45372 being exploited?

There is no known exploitation of CVE-2023-45372 in the wild and no public exploit code.

## Other vulnerabilities in Mediawiki Mediawiki

- [CVE-2023-37303](https://insights.sbomify.com/CVE-2023-37303/): Denial of service in n/a (critical 9.8)
- [CVE-2022-29904](https://insights.sbomify.com/CVE-2022-29904/): SQL injection in n/a (critical 9.8)
- [CVE-2022-29906](https://insights.sbomify.com/CVE-2022-29906/): Missing authorization in n/a (critical 9.8)
- [CVE-2022-28205](https://insights.sbomify.com/CVE-2022-28205/): Business logic in n/a (critical 9.8)
- [CVE-2022-28206](https://insights.sbomify.com/CVE-2022-28206/): Missing authorization in n/a (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-45372 and fix it if it is affected.

What it is: CVE-2023-45372 is a medium-severity vulnerability in Mediawiki Mediawiki, published on 9 Oct 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-45372 in the wild and no public exploit code.

Affected packages and fixed versions:
- mediawiki (Bitnami): affected all versions; fixed in 1.35.12, 1.39.5, 1.40.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-45372/ (Markdown: https://insights.sbomify.com/CVE-2023-45372/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-45372
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-45372
- OSV: https://osv.dev/vulnerability/CVE-2023-45372

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-45372/
Summaries are generated and may contain mistakes; the official description above is the record.
