CVE-2023-45373 Cross-site scripting in n/a
Cross-site scripting vulnerability in the ProofreadPage extension allows attackers to inject malicious scripts via the formatNumNoSeparators function.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2023-45373?
CVE-2023-45373 is a medium-severity cross-site scripting vulnerability in Mediawiki Mediawiki, published on 9 Oct 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
An issue was discovered in the ProofreadPage extension for MediaWiki before 1.35.12, 1.36.x through 1.39.x before 1.39.5, and 1.40.x before 1.40.1. XSS can occur via formatNumNoSeparators.
Weakness: CWE-79
Which versions are affected by CVE-2023-45373?
1 open source package ship an affected version, including mediawiki. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
mediawiki Bitnami | All versions | 1.35.12, 1.39.5, 1.40.1 |
Products include Mediawiki Mediawiki.
How do I fix CVE-2023-45373?
Upgrade mediawiki to a fixed version for your release line: 1.35.12, 1.39.5 or 1.40.1.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2023-45373 being exploited?
There is no known exploitation of CVE-2023-45373 in the wild and no public exploit code.
Other vulnerabilities in Mediawiki Mediawiki
Sources
Also known as BIT-mediawiki-2023-45373, GHSA-r83w-7pr5-mfp7.