# CVE-2023-45648: Apache Tomcat: Trailer header parsing too lenient

> Attackers can exploit improper trailer header parsing to perform request smuggling, bypassing security controls in Apache Tomcat deployments.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 10 Oct 2023
- **Updated:** 29 Oct 2025
- **Also known as:** BIT-tomcat-2023-45648, CLSA-2025-1738695770, DEBIAN-CVE-2023-45648, GHSA-r6j3-px5g-cq3x, OESA-2023-1788, UBUNTU-CVE-2023-45648

## What is CVE-2023-45648?

CVE-2023-45648 is a medium-severity vulnerability in Apache Tomcat, published on 10 Oct 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Improper Input Validation vulnerability in Apache Tomcat.Tomcat from 11.0.0-M1 through 11.0.0-M11, from 10.1.0-M1 through 10.1.13, from 9.0.0-M1 through 9.0.81 and from 8.5.0 through 8.5.93 did not correctly parse HTTP trailer headers. A specially 
crafted, invalid trailer header could cause Tomcat to treat a single 
request as multiple requests leading to the possibility of request 
smuggling when behind a reverse proxy.

Older, EOL versions may also be affected.

Users are recommended to upgrade to version 11.0.0-M12 onwards, 10.1.14 onwards, 9.0.81 onwards or 8.5.94 onwards, which fix the issue.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2023-45648?

25 open source packages ship an affected version, including org.apache.tomcat.embed:tomcat-embed-core, tomcat and org.apache.tomcat:tomcat. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.tomcat.embed:tomcat-embed-core` | Maven | From 10.1.0-M1 | 10.1.14 |
| `org.apache.tomcat.embed:tomcat-embed-core` | Maven | From 10.1.0-M1 | 10.1.14 |
| `org.apache.tomcat.embed:tomcat-embed-core` | Maven | From 11.0.0-M1 | 11.0.0-M12 |
| `org.apache.tomcat.embed:tomcat-embed-core` | Maven | From 11.0.0-M1 | 11.0.0-M12 |
| `org.apache.tomcat.embed:tomcat-embed-core` | Maven | From 8.5.0 | 8.5.94 |
| `org.apache.tomcat.embed:tomcat-embed-core` | Maven | From 8.5.0 | 8.5.94 |
| `org.apache.tomcat.embed:tomcat-embed-core` | Maven | From 9.0.0-M1 | 9.0.81 |
| `org.apache.tomcat.embed:tomcat-embed-core` | Maven | From 9.0.0-M1 | 9.0.81 |
| `tomcat` | Bitnami | From 8.5.0 | 8.5.94, 9.0.81, 10.1.14 |
| `org.apache.tomcat:tomcat` | Maven | From 10.1.0-M1 | 10.1.14 |
| `org.apache.tomcat:tomcat` | Maven | From 10.1.0-M1 | 10.1.14 |
| `org.apache.tomcat:tomcat` | Maven | From 11.0.0-M1 | 11.0.0-M12 |
| `org.apache.tomcat:tomcat` | Maven | From 11.0.0-M1 | 11.0.0-M12 |
| `org.apache.tomcat:tomcat` | Maven | From 8.5.0 | 8.5.94 |
| `org.apache.tomcat:tomcat` | Maven | From 8.5.0 | 8.5.94 |
| `org.apache.tomcat:tomcat` | Maven | From 9.0.0-M1 | 9.0.81 |
| `org.apache.tomcat:tomcat` | Maven | From 9.0.0-M1 | 9.0.81 |
| `org.apache.tomcat:tomcat-coyote` | Maven | From 10.1.0-M1 | 10.1.14 |
| `org.apache.tomcat:tomcat-coyote` | Maven | From 10.1.0-M1 | 10.1.14 |
| `org.apache.tomcat:tomcat-coyote` | Maven | From 11.0.0-M1 | 11.0.0-M12 |
| `org.apache.tomcat:tomcat-coyote` | Maven | From 11.0.0-M1 | 11.0.0-M12 |
| `org.apache.tomcat:tomcat-coyote` | Maven | From 8.5.0 | 8.5.94 |
| `org.apache.tomcat:tomcat-coyote` | Maven | From 8.5.0 | 8.5.94 |
| `org.apache.tomcat:tomcat-coyote` | Maven | From 9.0.0-M1 | 9.0.81 |
| `org.apache.tomcat:tomcat-coyote` | Maven | From 9.0.0-M1 | 9.0.81 |

Products: Apache Tomcat, Debian Debian Linux.

## How do I fix CVE-2023-45648?

Upgrade org.apache.tomcat.embed:tomcat-embed-core to a fixed version for your release line: 10.1.14, 11.0.0-M12, 8.5.94 or 9.0.81.

## Is CVE-2023-45648 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-45648 exists.

Public exploit code:

- Apache Tomcat - HTTP Request Smuggling (nuclei): http/cves/2023/CVE-2023-45648.yaml

## Other vulnerabilities in Apache Tomcat

- [CVE-2025-24813](https://insights.sbomify.com/CVE-2025-24813/): Apache Tomcat Path Equivalence (critical 10.0, exploited in the wild)
- [CVE-2016-8735](https://insights.sbomify.com/CVE-2016-8735/): Apache Tomcat Remote Code Execution (critical 9.8, exploited in the wild)
- [CVE-2017-12617](https://insights.sbomify.com/CVE-2017-12617/): Apache Tomcat Remote Code Execution (high 8.1, exploited in the wild)
- [CVE-2017-12615](https://insights.sbomify.com/CVE-2017-12615/): Apache Tomcat on Windows Remote Code Execution (high 8.1, exploited in the wild)
- [CVE-2026-34486](https://insights.sbomify.com/CVE-2026-34486/): Apache Tomcat Missing Encryption of Sensitive Data (high 7.5, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-45648 and fix it if it is affected.

What it is: CVE-2023-45648 is a medium-severity vulnerability in Apache Tomcat, published on 10 Oct 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-45648 exists.

Affected packages and fixed versions:
- org.apache.tomcat.embed:tomcat-embed-core (Maven): affected from 10.1.0-M1; fixed in 10.1.14
- org.apache.tomcat.embed:tomcat-embed-core (Maven): affected from 10.1.0-M1; fixed in 10.1.14
- org.apache.tomcat.embed:tomcat-embed-core (Maven): affected from 11.0.0-M1; fixed in 11.0.0-M12
- org.apache.tomcat.embed:tomcat-embed-core (Maven): affected from 11.0.0-M1; fixed in 11.0.0-M12
- org.apache.tomcat.embed:tomcat-embed-core (Maven): affected from 8.5.0; fixed in 8.5.94
- org.apache.tomcat.embed:tomcat-embed-core (Maven): affected from 8.5.0; fixed in 8.5.94
- org.apache.tomcat.embed:tomcat-embed-core (Maven): affected from 9.0.0-M1; fixed in 9.0.81
- org.apache.tomcat.embed:tomcat-embed-core (Maven): affected from 9.0.0-M1; fixed in 9.0.81
- tomcat (Bitnami): affected from 8.5.0; fixed in 8.5.94, 9.0.81, 10.1.14
- org.apache.tomcat:tomcat (Maven): affected from 10.1.0-M1; fixed in 10.1.14
- org.apache.tomcat:tomcat (Maven): affected from 10.1.0-M1; fixed in 10.1.14
- org.apache.tomcat:tomcat (Maven): affected from 11.0.0-M1; fixed in 11.0.0-M12

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-45648/ (Markdown: https://insights.sbomify.com/CVE-2023-45648/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-45648
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-45648
- OSV: https://osv.dev/vulnerability/CVE-2023-45648

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-45648/
Summaries are generated and may contain mistakes; the official description above is the record.
