# CVE-2023-45805: Trojan Lockfilein pdm

> Attackers can craft malicious lockfiles to install unintended packages, leading to arbitrary code execution during dependency installation.

- **Severity:** High 7.8 (`CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 20 Oct 2023
- **Updated:** 12 Sep 2024
- **Also known as:** DEBIAN-CVE-2023-45805, GHSA-j44v-mmf2-xvm9, PYSEC-2026-1763, UBUNTU-CVE-2023-45805, openSUSE-SU-2024:13352-1

## What is CVE-2023-45805?

CVE-2023-45805 is a high-severity vulnerability in pdm-project pdm, published on 20 Oct 2023. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

pdm is a Python package and dependency manager supporting the latest PEP standards. It's possible to craft a malicious `pdm.lock` file that could allow e.g. an insider or a malicious open source project to appear to depend on a trusted PyPI project, but actually install another project. A project `foo` can be targeted by creating the project `foo-2` and uploading the file `foo-2-2.tar.gz` to pypi.org. PyPI will see this as project `foo-2` version `2`, while PDM will see this as project `foo` version `2-2`. The version must only be `parseable as a version` and the filename must be a prefix of the project name, but it's not verified to match the version being installed. Version `2-2` is also not a valid normalized version per PEP 440. Matching the project name exactly (not just prefix) would fix the issue. When installing dependencies with PDM, what's actually installed could differ from what's listed in `pyproject.toml` (including arbitrary code execution on install). It could also be used for downgrade attacks by only changing the version. This issue has been addressed in commit `6853e2642df` which is included in release version `2.9.4`. Users are advised to upgrade. There are no known workarounds for this vulnerability.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2023-45805?

3 open source packages ship an affected version, including pdm. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pdm` | PyPI | All versions to 2.9.3 | None |
| `pdm` | PyPI | All versions to 2.9.3 | None |
| `pdm` | PyPI | All versions | 2.10.0 |

Products: Frostming Pdm, Frostming Unearth.

## How do I fix CVE-2023-45805?

Upgrade pdm to 2.10.0 or later.

## Is CVE-2023-45805 being exploited?

There is no known exploitation of CVE-2023-45805 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-45805 and fix it if it is affected.

What it is: CVE-2023-45805 is a high-severity vulnerability in pdm-project pdm, published on 20 Oct 2023. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2023-45805 in the wild and no public exploit code.

Affected packages and fixed versions:
- pdm (PyPI): affected all versions up to 2.9.3; no fix listed
- pdm (PyPI): affected all versions up to 2.9.3; no fix listed
- pdm (PyPI): affected all versions; fixed in 2.10.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-45805/ (Markdown: https://insights.sbomify.com/CVE-2023-45805/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-45805
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-45805
- OSV: https://osv.dev/vulnerability/CVE-2023-45805

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-45805/
Summaries are generated and may contain mistakes; the official description above is the record.
