{"answers":{"affected":"3 open source packages ship an affected version, including github.com/openfga/openfga. It affects 1 product.","exploited":"There is no known exploitation of CVE-2023-45810 in the wild and no public exploit code.","fix":"Upgrade github.com/openfga/openfga to 1.3.4 or later.","what":"CVE-2023-45810 is a medium-severity denial of service vulnerability in openfga, published on 17 Oct 2023. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2023-45810 and fix it if it is affected.\n\nWhat it is: CVE-2023-45810 is a medium-severity denial of service vulnerability in openfga, published on 17 Oct 2023. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2023-45810 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- github.com/openfga/openfga (Go): affected all versions; fixed in 1.3.4\n- github.com/openfga/openfga (Go): affected all versions; fixed in 1.3.4\n- github.com/openfga/openfga (Go): affected all versions; fixed in 1.3.4\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-45810/ (Markdown: https://insights.sbomify.com/CVE-2023-45810/index.md)","id":"CVE-2023-45810","markdown":"https://insights.sbomify.com/CVE-2023-45810/index.md","name":"CVE-2023-45810","record":{"aliases":["GHSA-hr4f-6jh8-f2vq","GO-2023-2121"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"OpenFGA authorization engine","requires_auth":"low_privilege","summary":"Attackers can cause OpenFGA to become unresponsive by triggering resource leaks via ListObjects calls, requiring an upgrade to fix.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"openfga","vendor":"openfga"}],"cvss":{"score":5.3,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-400","name":"Uncontrolled Resource Consumption"}],"description":"OpenFGA is a flexible authorization/permission engine built for developers and inspired by Google Zanzibar. Affected versions of OpenFGA are vulnerable to a denial of service attack. When a number of `ListObjects` calls are executed, in some scenarios, those calls are not releasing resources even after a response has been sent, and given a sufficient call volume the service as a whole becomes unresponsive. This issue has been addressed in version 1.3.4 and the upgrade is considered backwards compatible. There are no known workarounds for this vulnerability.","ecosystems":["Go"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"OpenFGA denial of service","id":"CVE-2023-45810","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Go","product":null,"products":[],"type":"denial_of_service","year":"2023"},"n_packages":3,"n_references":1,"next":{"headline":"Prototype pollution vulnerability leading to arbitrary code execution in synchrony deobfuscator","id":"CVE-2023-45811"},"packages":[{"ecosystem":"Go","fixed":["1.3.4"],"introduced":["0"],"last_affected":[],"package":"github.com/openfga/openfga","purl":null,"source":"GHSA-hr4f-6jh8-f2vq"},{"ecosystem":"Go","fixed":["1.3.4"],"introduced":["0"],"last_affected":[],"package":"github.com/openfga/openfga","purl":"pkg:golang/github.com/openfga/openfga","source":"GHSA-hr4f-6jh8-f2vq"},{"ecosystem":"Go","fixed":["1.3.4"],"introduced":["0"],"last_affected":[],"package":"github.com/openfga/openfga","purl":"pkg:golang/github.com/openfga/openfga","source":"GO-2023-2121"}],"prev":{"headline":"Disclosure of user names via admin bulk action views in wagtail","id":"CVE-2023-45809"},"products":["openfga"],"published":"2023-10-17","related":[{"cvss_score":8.1,"headline":"OpenFGA Authorization Bypass","id":"CVE-2024-31452","kev_date_added":null,"published":"2024-04-16"},{"cvss_score":7.7,"headline":"OpenFGA Authorization Bypass","id":"CVE-2022-23542","kev_date_added":null,"published":"2022-12-20"},{"cvss_score":7.5,"headline":"OpenFGA Authorization Bypass","id":"CVE-2024-42473","kev_date_added":null,"published":"2024-08-09"},{"cvss_score":6.5,"headline":"OpenFGA Playground Preshared Key Exposure","id":"CVE-2026-40293","kev_date_added":null,"published":"2026-04-17"},{"cvss_score":6.5,"headline":"OpenFGA Authorization Bypass","id":"CVE-2023-40579","kev_date_added":null,"published":"2023-08-25"},{"cvss_score":5.9,"headline":"Denial of service from circular relationship definitions in OpenFGA","id":"CVE-2023-43645","kev_date_added":null,"published":"2023-09-26"},{"cvss_score":5.9,"headline":"OpenFGA denial of service die to circular relationship","id":"CVE-2023-35933","kev_date_added":null,"published":"2023-06-26"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"Go Vulnerability Database","prefix":"GO"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-09-13","vendors":["openfga"]},"summary":"Attackers can cause OpenFGA to become unresponsive by triggering resource leaks via ListObjects calls, requiring an upgrade to fix.","url":"https://insights.sbomify.com/CVE-2023-45810/"}