# CVE-2023-45810: OpenFGA denial of service

> Attackers can cause OpenFGA to become unresponsive by triggering resource leaks via ListObjects calls, requiring an upgrade to fix.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 17 Oct 2023
- **Updated:** 13 Sep 2024
- **Also known as:** GHSA-hr4f-6jh8-f2vq, GO-2023-2121

## What is CVE-2023-45810?

CVE-2023-45810 is a medium-severity denial of service vulnerability in openfga, published on 17 Oct 2023. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

OpenFGA is a flexible authorization/permission engine built for developers and inspired by Google Zanzibar. Affected versions of OpenFGA are vulnerable to a denial of service attack. When a number of `ListObjects` calls are executed, in some scenarios, those calls are not releasing resources even after a response has been sent, and given a sufficient call volume the service as a whole becomes unresponsive. This issue has been addressed in version 1.3.4 and the upgrade is considered backwards compatible. There are no known workarounds for this vulnerability.

Weakness: CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2023-45810?

3 open source packages ship an affected version, including github.com/openfga/openfga. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/openfga/openfga` | Go | All versions | 1.3.4 |
| `github.com/openfga/openfga` | Go | All versions | 1.3.4 |
| `github.com/openfga/openfga` | Go | All versions | 1.3.4 |

Products: Openfga Openfga.

## How do I fix CVE-2023-45810?

Upgrade github.com/openfga/openfga to 1.3.4 or later.

## Is CVE-2023-45810 being exploited?

There is no known exploitation of CVE-2023-45810 in the wild and no public exploit code.

## Other vulnerabilities in openfga

- [CVE-2024-31452](https://insights.sbomify.com/CVE-2024-31452/): OpenFGA Authorization Bypass (high 8.1)
- [CVE-2022-23542](https://insights.sbomify.com/CVE-2022-23542/): OpenFGA Authorization Bypass (high 7.7)
- [CVE-2024-42473](https://insights.sbomify.com/CVE-2024-42473/): OpenFGA Authorization Bypass (high 7.5)
- [CVE-2026-40293](https://insights.sbomify.com/CVE-2026-40293/): OpenFGA Playground Preshared Key Exposure (medium 6.5)
- [CVE-2023-40579](https://insights.sbomify.com/CVE-2023-40579/): OpenFGA Authorization Bypass (medium 6.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-45810 and fix it if it is affected.

What it is: CVE-2023-45810 is a medium-severity denial of service vulnerability in openfga, published on 17 Oct 2023. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-45810 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/openfga/openfga (Go): affected all versions; fixed in 1.3.4
- github.com/openfga/openfga (Go): affected all versions; fixed in 1.3.4
- github.com/openfga/openfga (Go): affected all versions; fixed in 1.3.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-45810/ (Markdown: https://insights.sbomify.com/CVE-2023-45810/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-45810
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-45810
- OSV: https://osv.dev/vulnerability/CVE-2023-45810

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-45810/
Summaries are generated and may contain mistakes; the official description above is the record.
