{"answers":{"affected":"2 open source packages ship an affected version, including deobfuscator. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-45811 exists.","fix":"Upgrade deobfuscator to 2.4.4 or later.","what":"CVE-2023-45811 is a high-severity code injection vulnerability in relative synchrony, published on 17 Oct 2023. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2023-45811 and fix it if it is affected.\n\nWhat it is: CVE-2023-45811 is a high-severity code injection vulnerability in relative synchrony, published on 17 Oct 2023. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-45811 exists.\n\nAffected packages and fixed versions:\n- deobfuscator (npm): affected from 2.0.1; fixed in 2.4.4\n- deobfuscator (npm): affected from 2.0.1; fixed in 2.4.4\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-45811/ (Markdown: https://insights.sbomify.com/CVE-2023-45811/index.md)","id":"CVE-2023-45811","markdown":"https://insights.sbomify.com/CVE-2023-45811/index.md","name":"CVE-2023-45811","record":{"aliases":["GHSA-jg82-xh3w-rhxx"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"JavaScript deobfuscator library","requires_auth":"none","summary":"Prototype pollution in the Synchrony deobfuscator library allows attackers to execute arbitrary code via crafted input.","user_interaction":"not_required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"synchrony","vendor":"relative"}],"cvss":{"score":8.2,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:L/AC:H/PR:N/UI:N/S:C/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-1321","name":"Improperly Controlled Modification of Object Prototype Attributes"}],"description":"Synchrony deobfuscator is a javascript cleaner \u0026 deobfuscator.  A `__proto__` pollution vulnerability exists in versions before v2.4.4. Successful exploitation could lead to arbitrary code execution. A `__proto__` pollution vulnerability exists in the `LiteralMap` transformer allowing crafted input to modify properties in the Object prototype. A fix has been released in `deobfuscator@2.4.4`. Users are advised to upgrade. Users unable to upgrade should launch node with the [--disable-proto=delete][disable-proto] or [--disable-proto=throw][disable-proto] flags","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Prototype pollution vulnerability leading to arbitrary code execution in synchrony deobfuscator","id":"CVE-2023-45811","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"code_injection","year":"2023"},"n_packages":2,"n_references":3,"next":{"headline":"Improper Check or Handling of Exceptional Conditions in apollo-router","id":"CVE-2023-45812"},"packages":[{"ecosystem":"npm","fixed":["2.4.4"],"introduced":["2.0.1"],"last_affected":[],"package":"deobfuscator","purl":null,"source":"GHSA-jg82-xh3w-rhxx"},{"ecosystem":"npm","fixed":["2.4.4"],"introduced":["2.0.1"],"last_affected":[],"package":"deobfuscator","purl":"pkg:npm/deobfuscator","source":"GHSA-jg82-xh3w-rhxx"}],"prev":{"headline":"OpenFGA denial of service","id":"CVE-2023-45810"},"products":["synchrony"],"published":"2023-10-17","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2024-09-13","vendors":["relative"]},"summary":"Prototype pollution in the Synchrony deobfuscator library allows attackers to execute arbitrary code via crafted input.","url":"https://insights.sbomify.com/CVE-2023-45811/"}