# CVE-2023-45811: Prototype pollution vulnerability leading to arbitrary code execution in synchrony deobfuscator

> Prototype pollution in the Synchrony deobfuscator library allows attackers to execute arbitrary code via crafted input.

- **Severity:** High 8.2 (`CVSS:3.1/AV:L/AC:H/PR:N/UI:N/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 17 Oct 2023
- **Updated:** 13 Sep 2024
- **Also known as:** GHSA-jg82-xh3w-rhxx

## What is CVE-2023-45811?

CVE-2023-45811 is a high-severity code injection vulnerability in relative synchrony, published on 17 Oct 2023. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

Synchrony deobfuscator is a javascript cleaner & deobfuscator.  A `__proto__` pollution vulnerability exists in versions before v2.4.4. Successful exploitation could lead to arbitrary code execution. A `__proto__` pollution vulnerability exists in the `LiteralMap` transformer allowing crafted input to modify properties in the Object prototype. A fix has been released in `deobfuscator@2.4.4`. Users are advised to upgrade. Users unable to upgrade should launch node with the [--disable-proto=delete][disable-proto] or [--disable-proto=throw][disable-proto] flags

Weakness: CWE-1321 (Improperly Controlled Modification of Object Prototype Attributes)

## Which versions are affected by CVE-2023-45811?

2 open source packages ship an affected version, including deobfuscator. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `deobfuscator` | npm | From 2.0.1 | 2.4.4 |
| `deobfuscator` | npm | From 2.0.1 | 2.4.4 |

Products: Relative Synchrony.

## How do I fix CVE-2023-45811?

Upgrade deobfuscator to 2.4.4 or later.

## Is CVE-2023-45811 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-45811 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-45811 and fix it if it is affected.

What it is: CVE-2023-45811 is a high-severity code injection vulnerability in relative synchrony, published on 17 Oct 2023. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-45811 exists.

Affected packages and fixed versions:
- deobfuscator (npm): affected from 2.0.1; fixed in 2.4.4
- deobfuscator (npm): affected from 2.0.1; fixed in 2.4.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-45811/ (Markdown: https://insights.sbomify.com/CVE-2023-45811/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-45811
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-45811
- OSV: https://osv.dev/vulnerability/CVE-2023-45811

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-45811/
Summaries are generated and may contain mistakes; the official description above is the record.
