# CVE-2023-45816: Unread bookmark reminder notifications that the user cannot access can be seen

> Attackers can view unread bookmark notifications for resources they no longer have access to, leaking information about restricted content.

- **Severity:** Low 3.3 (`CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 10 Nov 2023
- **Updated:** 3 Sep 2024
- **Also known as:** BIT-discourse-2023-45816, GHSA-v9r6-92wp-f6cf

## What is CVE-2023-45816?

CVE-2023-45816 is a low-severity vulnerability in Discourse Discourse, published on 10 Nov 2023. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

Discourse is an open source platform for community discussion. Prior to version 3.1.3 of the `stable` branch and version 3.2.0.beta3 of the `beta` and `tests-passed` branches, there is an edge case where a bookmark reminder is sent and an unread notification is generated, but the underlying bookmarkable (e.g. post, topic, chat message) security has changed, making it so the user can no longer access the underlying resource. As of version 3.1.3 of the `stable` branch and version 3.2.0.beta3 of the `beta` and `tests-passed` branches, bookmark reminders are now no longer sent if the user does not have access to the underlying bookmarkable, and also the unread bookmark notifications are always filtered by access. There are no known workarounds.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2023-45816?

1 open source package ship an affected version, including discourse. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `discourse` | Bitnami | All versions | 3.2.0 |

Products: Discourse Discourse.

## How do I fix CVE-2023-45816?

Upgrade discourse to 3.2.0 or later.

## Is CVE-2023-45816 being exploited?

There is no known exploitation of CVE-2023-45816 in the wild and no public exploit code.

## Other vulnerabilities in Discourse Discourse

- [CVE-2021-41163](https://insights.sbomify.com/CVE-2021-41163/): RCE via malicious SNS subscription payload (critical 10.0)
- [CVE-2022-36066](https://insights.sbomify.com/CVE-2022-36066/): Discourse vulnerable to RCE via admins uploading maliciously zipped file (critical 9.1)
- [CVE-2022-39356](https://insights.sbomify.com/CVE-2022-39356/): Discourse user account takeover via email and invite link (high 8.9)
- [CVE-2023-22468](https://insights.sbomify.com/CVE-2023-22468/): Discourse vulnerable to Cross-site Scripting in local oneboxes (high 8.8)
- [CVE-2026-27934](https://insights.sbomify.com/CVE-2026-27934/): Discourse leaks private topic title and post excerpt via user action API endpoint (high 8.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-45816 and fix it if it is affected.

What it is: CVE-2023-45816 is a low-severity vulnerability in Discourse Discourse, published on 10 Nov 2023. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2023-45816 in the wild and no public exploit code.

Affected packages and fixed versions:
- discourse (Bitnami): affected all versions; fixed in 3.2.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-45816/ (Markdown: https://insights.sbomify.com/CVE-2023-45816/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-45816
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-45816
- OSV: https://osv.dev/vulnerability/CVE-2023-45816

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-45816/
Summaries are generated and may contain mistakes; the official description above is the record.
