# CVE-2023-45819: Cross-site Scripting vulnerability in TinyMCE notificationManager.open API

> Attackers can execute arbitrary JavaScript via unfiltered HTML in TinyMCE notifications, requiring an upgrade to patched versions.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 19 Oct 2023
- **Updated:** 12 Sep 2024
- **Also known as:** GHSA-hgqx-r2hp-jr38, UBUNTU-CVE-2023-45819

## What is CVE-2023-45819?

CVE-2023-45819 is a medium-severity cross-site scripting vulnerability in tinymce, published on 19 Oct 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

TinyMCE is an open source rich text editor. A cross-site scripting (XSS) vulnerability was discovered in TinyMCE’s Notification Manager API. The vulnerability exploits TinyMCE's unfiltered notification system, which is used in error handling. The conditions for this exploit requires carefully crafted malicious content to have been inserted into the editor and a notification to have been triggered. When a notification was opened, the HTML within the text argument was displayed unfiltered in the notification. The vulnerability allowed arbitrary JavaScript execution when an notification presented in the TinyMCE UI for the current user.  This issue could also be exploited by any integration which uses a TinyMCE notification to display unfiltered HTML content. This vulnerability has been patched in TinyMCE 5.10.8 and TinyMCE 6.7.1 by ensuring that the HTML displayed in the notification is sanitized, preventing the exploit. Users are advised to upgrade. There are no known workarounds for this vulnerability.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2023-45819?

12 open source packages ship an affected version, including TinyMCE, tinymce/tinymce and tinymce. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `TinyMCE` | NuGet | All versions | 5.10.8 |
| `TinyMCE` | NuGet | All versions | 5.10.8 |
| `TinyMCE` | NuGet | From 6.0.0 | 6.7.1 |
| `TinyMCE` | NuGet | From 6.0.0 | 6.7.1 |
| `tinymce/tinymce` | Packagist | All versions | 5.10.8 |
| `tinymce/tinymce` | Packagist | All versions | 5.10.8 |
| `tinymce/tinymce` | Packagist | From 6.0.0 | 6.7.1 |
| `tinymce/tinymce` | Packagist | From 6.0.0 | 6.7.1 |
| `tinymce` | npm | All versions | 5.10.8 |
| `tinymce` | npm | All versions | 5.10.8 |
| `tinymce` | npm | From 6.0.0 | 6.7.1 |
| `tinymce` | npm | From 6.0.0 | 6.7.1 |

Products: Tiny Tinymce.

## How do I fix CVE-2023-45819?

Upgrade TinyMCE to a fixed version for your release line: 5.10.8 or 6.7.1.

## Is CVE-2023-45819 being exploited?

There is no known exploitation of CVE-2023-45819 in the wild and no public exploit code.

## Other vulnerabilities in tinymce

- [CVE-2026-47759](https://insights.sbomify.com/CVE-2026-47759/): TinyMCE Cross-Site Scripting (XSS) vulnerability using through data-mce- prefixed src, href, style attributes (high 8.7)
- [CVE-2026-47760](https://insights.sbomify.com/CVE-2026-47760/): TinyMCE Cross-Site Scripting (XSS) vulnerability using sanitization bypass through nested SVGs (high 8.7)
- [CVE-2026-47761](https://insights.sbomify.com/CVE-2026-47761/): TinyMCE Cross-Site Scripting (XSS) vulnerability using media plugin `data-mce-object` injection (high 8.7)
- [CVE-2026-47762](https://insights.sbomify.com/CVE-2026-47762/): TinyMCE Cross-Site Scripting (XSS) vulnerability through `mce:protected` comments (high 8.7)
- [CVE-2024-21908](https://insights.sbomify.com/CVE-2024-21908/): Cross-site scripting vulnerability in TinyMCE (medium 6.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-45819 and fix it if it is affected.

What it is: CVE-2023-45819 is a medium-severity cross-site scripting vulnerability in tinymce, published on 19 Oct 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2023-45819 in the wild and no public exploit code.

Affected packages and fixed versions:
- TinyMCE (NuGet): affected all versions; fixed in 5.10.8
- TinyMCE (NuGet): affected all versions; fixed in 5.10.8
- TinyMCE (NuGet): affected from 6.0.0; fixed in 6.7.1
- TinyMCE (NuGet): affected from 6.0.0; fixed in 6.7.1
- tinymce/tinymce (Packagist): affected all versions; fixed in 5.10.8
- tinymce/tinymce (Packagist): affected all versions; fixed in 5.10.8
- tinymce/tinymce (Packagist): affected from 6.0.0; fixed in 6.7.1
- tinymce/tinymce (Packagist): affected from 6.0.0; fixed in 6.7.1
- tinymce (npm): affected all versions; fixed in 5.10.8
- tinymce (npm): affected all versions; fixed in 5.10.8
- tinymce (npm): affected from 6.0.0; fixed in 6.7.1
- tinymce (npm): affected from 6.0.0; fixed in 6.7.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-45819/ (Markdown: https://insights.sbomify.com/CVE-2023-45819/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-45819
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-45819
- OSV: https://osv.dev/vulnerability/CVE-2023-45819

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-45819/
Summaries are generated and may contain mistakes; the official description above is the record.
