{"answers":{"affected":"2 open source packages ship an affected version, including directus. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-45820 exists.","fix":"Upgrade directus to 10.6.2 or later.","what":"CVE-2023-45820 is a medium-severity denial of service vulnerability in Monospace Directus, published on 19 Oct 2023. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2023-45820 and fix it if it is affected.\n\nWhat it is: CVE-2023-45820 is a medium-severity denial of service vulnerability in Monospace Directus, published on 19 Oct 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-45820 exists.\n\nAffected packages and fixed versions:\n- directus (npm): affected from 10.4.0; fixed in 10.6.2\n- directus (npm): affected from 10.4.0; fixed in 10.6.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-45820/ (Markdown: https://insights.sbomify.com/CVE-2023-45820/index.md)","id":"CVE-2023-45820","markdown":"https://insights.sbomify.com/CVE-2023-45820/index.md","name":"CVE-2023-45820","record":{"aliases":["GHSA-hmgw-9jrg-hf2m"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":true,"product_category":"Directus API dashboard","requires_auth":"none","summary":"An attacker can crash the Directus application by sending invalid WebSocket frames, requiring websockets to be enabled.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"directus","vendor":"monospace"}],"cvss":{"score":5.9,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-755","name":"Improper Handling of Exceptional Conditions"}],"description":"Directus is a real-time API and App dashboard for managing SQL database content. In affected versions any Directus installation that has websockets enabled can be crashed if the websocket server receives an invalid frame. A malicious user could leverage this bug to crash Directus. This issue has been addressed in version 10.6.2. Users are advised to upgrade. Users unable to upgrade should avoid using websockets.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Directus crashes on invalid WebSocket message","id":"CVE-2023-45820","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":"monospace:directus","products":["monospace:directus"],"type":"denial_of_service","year":"2023"},"n_packages":2,"n_references":2,"next":{"headline":"Incorrect Docker Hub registry check in Artifact Hub","id":"CVE-2023-45821"},"packages":[{"ecosystem":"npm","fixed":["10.6.2"],"introduced":["10.4.0"],"last_affected":[],"package":"directus","purl":null,"source":"GHSA-hmgw-9jrg-hf2m"},{"ecosystem":"npm","fixed":["10.6.2"],"introduced":["10.4.0"],"last_affected":[],"package":"directus","purl":"pkg:npm/directus","source":"GHSA-hmgw-9jrg-hf2m"}],"prev":{"headline":"Cross-site Scripting vulnerability in TinyMCE notificationManager.open API","id":"CVE-2023-45819"},"products":["directus"],"published":"2023-10-19","related":[{"cvss_score":9.8,"headline":"Insecure default value for CORS configuration","id":"CVE-2022-26969","kev_date_added":null,"published":"2022-12-26"},{"cvss_score":9.3,"headline":"Directus allows unauthenticated file upload and file modification due to lacking input sanitization","id":"CVE-2025-55746","kev_date_added":null,"published":"2025-08-20"},{"cvss_score":8.7,"headline":"Directus is Missing Cross-Origin Opener Policy","id":"CVE-2026-35408","kev_date_added":null,"published":"2026-04-06"},{"cvss_score":8.6,"headline":"Directus: Authorization-dependent response served from unsegmented cache key","id":"CVE-2026-61836","kev_date_added":null,"published":"2026-07-15"},{"cvss_score":8.6,"headline":"Directus's webhook trigger flows can leak sensitive data","id":"CVE-2025-30353","kev_date_added":null,"published":"2025-03-26"},{"cvss_score":8.5,"headline":"Directus has a Path Traversal and Broken Access Control in File Management API","id":"CVE-2026-39942","kev_date_added":null,"published":"2026-04-09"},{"cvss_score":8.2,"headline":"Directus MySQL accent insensitive email matching","id":"CVE-2024-27295","kev_date_added":null,"published":"2024-03-01"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-09-12","vendors":["directus"]},"summary":"An attacker can crash the Directus application by sending invalid WebSocket frames, requiring websockets to be enabled.","url":"https://insights.sbomify.com/CVE-2023-45820/"}