# CVE-2023-45820: Directus crashes on invalid WebSocket message

> An attacker can crash the Directus application by sending invalid WebSocket frames, requiring websockets to be enabled.

- **Severity:** Medium 5.9 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 19 Oct 2023
- **Updated:** 12 Sep 2024
- **Also known as:** GHSA-hmgw-9jrg-hf2m

## What is CVE-2023-45820?

CVE-2023-45820 is a medium-severity denial of service vulnerability in Monospace Directus, published on 19 Oct 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Directus is a real-time API and App dashboard for managing SQL database content. In affected versions any Directus installation that has websockets enabled can be crashed if the websocket server receives an invalid frame. A malicious user could leverage this bug to crash Directus. This issue has been addressed in version 10.6.2. Users are advised to upgrade. Users unable to upgrade should avoid using websockets.

Weakness: CWE-755 (Improper Handling of Exceptional Conditions)

## Which versions are affected by CVE-2023-45820?

2 open source packages ship an affected version, including directus. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `directus` | npm | From 10.4.0 | 10.6.2 |
| `directus` | npm | From 10.4.0 | 10.6.2 |

Products: Monospace Directus.

## How do I fix CVE-2023-45820?

Upgrade directus to 10.6.2 or later.

## Is CVE-2023-45820 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-45820 exists.

## Other vulnerabilities in Monospace Directus

- [CVE-2022-26969](https://insights.sbomify.com/CVE-2022-26969/): Insecure default value for CORS configuration (critical 9.8)
- [CVE-2025-55746](https://insights.sbomify.com/CVE-2025-55746/): Directus allows unauthenticated file upload and file modification due to lacking input sanitization (critical 9.3)
- [CVE-2026-35408](https://insights.sbomify.com/CVE-2026-35408/): Directus is Missing Cross-Origin Opener Policy (high 8.7)
- [CVE-2026-61836](https://insights.sbomify.com/CVE-2026-61836/): Directus: Authorization-dependent response served from unsegmented cache key (high 8.6)
- [CVE-2025-30353](https://insights.sbomify.com/CVE-2025-30353/): Directus's webhook trigger flows can leak sensitive data (high 8.6)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-45820 and fix it if it is affected.

What it is: CVE-2023-45820 is a medium-severity denial of service vulnerability in Monospace Directus, published on 19 Oct 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-45820 exists.

Affected packages and fixed versions:
- directus (npm): affected from 10.4.0; fixed in 10.6.2
- directus (npm): affected from 10.4.0; fixed in 10.6.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-45820/ (Markdown: https://insights.sbomify.com/CVE-2023-45820/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-45820
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-45820
- OSV: https://osv.dev/vulnerability/CVE-2023-45820

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-45820/
Summaries are generated and may contain mistakes; the official description above is the record.
