# CVE-2023-45821: Incorrect Docker Hub registry check in Artifact Hub

> Attackers can hijack Docker Hub credentials by spoofing a domain ending in docker.io, potentially exposing read-only public content access.

- **Severity:** Medium 5.4 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 19 Oct 2023
- **Updated:** 12 Sep 2024
- **Also known as:** GHSA-g6pq-x539-7w4j, GO-2023-2135

## What is CVE-2023-45821?

CVE-2023-45821 is a medium-severity vulnerability in artifacthub hub, published on 19 Oct 2023. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Artifact Hub is a web-based application that enables finding, installing, and publishing packages and configurations for CNCF projects. During a security audit of Artifact Hub's code base a security researcher identified a bug in which the `registryIsDockerHub` function was only checking that the registry domain had the `docker.io` suffix. Artifact Hub allows providing some Docker credentials that are used to increase the rate limit applied when interacting with the Docker Hub registry API to read publicly available content. Due to the incorrect check described above, it'd be possible to hijack those credentials by purchasing a domain which ends with `docker.io` and deploying a fake OCI registry on it. <https://artifacthub.io/> uses some credentials that only have permissions to read public content available in the Docker Hub. However, even though credentials for private repositories (disabled on `artifacthub.io`) are handled in a different way, other Artifact Hub deployments could have been using them for a different purpose. This issue has been resolved in version `1.16.0`. Users are advised to upgrade. There are no known workarounds for this vulnerability.

Weakness: CWE-494 (Download of Code Without Integrity Check)

## Which versions are affected by CVE-2023-45821?

3 open source packages ship an affected version, including github.com/artifacthub/hub. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/artifacthub/hub` | Go | All versions | 1.16.0 |
| `github.com/artifacthub/hub` | Go | All versions | 1.16.0 |
| `github.com/artifacthub/hub` | Go | All versions | 1.16.0 |

Products: Artifacthub Hub.

## How do I fix CVE-2023-45821?

Upgrade github.com/artifacthub/hub to 1.16.0 or later.

## Is CVE-2023-45821 being exploited?

There is no known exploitation of CVE-2023-45821 in the wild and no public exploit code.

## Other vulnerabilities in artifacthub hub

- [CVE-2023-45823](https://insights.sbomify.com/CVE-2023-45823/): Arbitrary file read in Artifact Hub (high 7.5)
- [CVE-2023-45822](https://insights.sbomify.com/CVE-2023-45822/): Unsafe rego built-in allowed in Artifact Hub (low 3.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-45821 and fix it if it is affected.

What it is: CVE-2023-45821 is a medium-severity vulnerability in artifacthub hub, published on 19 Oct 2023. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-45821 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/artifacthub/hub (Go): affected all versions; fixed in 1.16.0
- github.com/artifacthub/hub (Go): affected all versions; fixed in 1.16.0
- github.com/artifacthub/hub (Go): affected all versions; fixed in 1.16.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-45821/ (Markdown: https://insights.sbomify.com/CVE-2023-45821/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-45821
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-45821
- OSV: https://osv.dev/vulnerability/CVE-2023-45821

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-45821/
Summaries are generated and may contain mistakes; the official description above is the record.
