# CVE-2023-45822: Unsafe rego built-in allowed in Artifact Hub

> Attackers can exploit unsafe Rego policies to perform Server-Side Request Forgery, accessing internal resources and exfiltrating data.

- **Severity:** Low 3.7 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 19 Oct 2023
- **Updated:** 12 Sep 2024
- **Also known as:** GHSA-9pc8-m4vp-ggvf, GO-2023-2134

## What is CVE-2023-45822?

CVE-2023-45822 is a low-severity server-side request forgery vulnerability in artifacthub hub, published on 19 Oct 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Artifact Hub is a web-based application that enables finding, installing, and publishing packages and configurations for CNCF projects. During a security audit of Artifact Hub's code base a security researcher identified a bug in which a default unsafe rego built-in was allowed to be used when defining authorization policies. Artifact Hub includes a fine-grained authorization mechanism that allows organizations to define what actions can be performed by their members. It is based on customizable authorization policies that are enforced by the `Open Policy Agent`. Policies are written using `rego` and their data files are expected to be json documents. By default, `rego` allows policies to make HTTP requests, which can be abused to send requests to internal resources and forward the responses to an external entity. In the context of Artifact Hub, this capability should have been disabled. This issue has been resolved in version `1.16.0`. Users are advised to upgrade. There are no known workarounds for this vulnerability.

Weakness: CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2023-45822?

3 open source packages ship an affected version, including github.com/artifacthub/hub. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/artifacthub/hub` | Go | All versions | 1.16.0 |
| `github.com/artifacthub/hub` | Go | All versions | 1.16.0 |
| `github.com/artifacthub/hub` | Go | All versions | 1.16.0 |

Products: Artifacthub Hub.

## How do I fix CVE-2023-45822?

Upgrade github.com/artifacthub/hub to 1.16.0 or later.

## Is CVE-2023-45822 being exploited?

There is no known exploitation of CVE-2023-45822 in the wild and no public exploit code.

## Other vulnerabilities in artifacthub hub

- [CVE-2023-45823](https://insights.sbomify.com/CVE-2023-45823/): Arbitrary file read in Artifact Hub (high 7.5)
- [CVE-2023-45821](https://insights.sbomify.com/CVE-2023-45821/): Incorrect Docker Hub registry check in Artifact Hub (medium 5.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-45822 and fix it if it is affected.

What it is: CVE-2023-45822 is a low-severity server-side request forgery vulnerability in artifacthub hub, published on 19 Oct 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-45822 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/artifacthub/hub (Go): affected all versions; fixed in 1.16.0
- github.com/artifacthub/hub (Go): affected all versions; fixed in 1.16.0
- github.com/artifacthub/hub (Go): affected all versions; fixed in 1.16.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-45822/ (Markdown: https://insights.sbomify.com/CVE-2023-45822/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-45822
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-45822
- OSV: https://osv.dev/vulnerability/CVE-2023-45822

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-45822/
Summaries are generated and may contain mistakes; the official description above is the record.
