CVE-2023-45859 Missing permission checks on Hazelcast client protocol

High 7.6 Published Updated

Authenticated users can bypass permission checks to access unauthorized data stored in the Hazelcast cluster.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2023-45859?

CVE-2023-45859 is a high-severity missing authorization vulnerability in n/a, published on 28 Feb 2024. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

In Hazelcast through 4.1.10, 4.2 through 4.2.8, 5.0 through 5.0.5, 5.1 through 5.1.7, 5.2 through 5.2.4, and 5.3 through 5.3.2, some client operations don't check permissions properly, allowing authenticated users to access data stored in the cluster.

Weakness: CWE-922

Which versions are affected by CVE-2023-45859?

16 open source packages ship an affected version, including com.hazelcast:hazelcast and com.hazelcast:hazelcast-all. It affects 1 product.

PackageAffectedFixed in
com.hazelcast:hazelcast MavenAll versions to 4.1.10None
com.hazelcast:hazelcast MavenAll versions to 4.1.10None
com.hazelcast:hazelcast MavenFrom 4.2 to 4.2.8None
com.hazelcast:hazelcast MavenFrom 4.2 to 4.2.8None
com.hazelcast:hazelcast MavenFrom 5.0 to 5.0.5None
com.hazelcast:hazelcast MavenFrom 5.0 to 5.0.5None
10 more packages
com.hazelcast:hazelcast MavenFrom 5.1 to 5.1.7None
com.hazelcast:hazelcast MavenFrom 5.1 to 5.1.7None
com.hazelcast:hazelcast MavenFrom 5.2.05.2.5
com.hazelcast:hazelcast MavenFrom 5.2.05.2.5
com.hazelcast:hazelcast MavenFrom 5.3.05.3.5
com.hazelcast:hazelcast MavenFrom 5.3.05.3.5
com.hazelcast:hazelcast-all MavenAll versions to 4.1.10None
com.hazelcast:hazelcast-all MavenAll versions to 4.1.10None
com.hazelcast:hazelcast-all MavenFrom 4.2 to 4.2.8None
com.hazelcast:hazelcast-all MavenFrom 4.2 to 4.2.8None

Products include Hazelcast Hazelcast.

How do I fix CVE-2023-45859?

Upgrade com.hazelcast:hazelcast to a fixed version for your release line: 5.2.5 or 5.3.5.

Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.

Is CVE-2023-45859 being exploited?

There is no known exploitation of CVE-2023-45859 in the wild and no public exploit code.

Sources

Also known as GHSA-xh6m-7cr7-xx66.

Is CVE-2023-45859 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free