CVE-2023-45860 Hazelcast Platform permission checking in CSV File Source connector
Unauthorized clients can access data from files on the server filesystem due to inadequate permission checking in the CSV File Source connector.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2023-45860?
CVE-2023-45860 is a medium-severity missing authorization vulnerability in n/a, published on 16 Feb 2024. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
In Hazelcast Platform through 5.3.4, a security issue exists within the SQL mapping for the CSV File Source connector. This issue arises from inadequate permission checking, which could enable unauthorized clients to access data from files stored on a member's filesystem.
Weakness: CWE-89
Which versions are affected by CVE-2023-45860?
12 open source packages ship an affected version, including com.hazelcast:hazelcast and com.hazelcast:hazelcast-enterprise. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
com.hazelcast:hazelcast Maven | All versions to 5.1.7 | None |
com.hazelcast:hazelcast Maven | All versions to 5.1.7 | None |
com.hazelcast:hazelcast Maven | From 5.2.0 | 5.2.5 |
com.hazelcast:hazelcast Maven | From 5.2.0 | 5.2.5 |
com.hazelcast:hazelcast Maven | From 5.3.0 | 5.3.5 |
com.hazelcast:hazelcast Maven | From 5.3.0 | 5.3.5 |
6 more packages
com.hazelcast:hazelcast-enterprise Maven | All versions to 5.1.7 | None |
com.hazelcast:hazelcast-enterprise Maven | All versions to 5.1.7 | None |
com.hazelcast:hazelcast-enterprise Maven | From 5.2.0 | 5.2.5 |
com.hazelcast:hazelcast-enterprise Maven | From 5.2.0 | 5.2.5 |
com.hazelcast:hazelcast-enterprise Maven | From 5.3.0 | 5.3.5 |
com.hazelcast:hazelcast-enterprise Maven | From 5.3.0 | 5.3.5 |
Products include Hazelcast Hazelcast.
How do I fix CVE-2023-45860?
Upgrade com.hazelcast:hazelcast to a fixed version for your release line: 5.2.5 or 5.3.5.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2023-45860 being exploited?
There is no known exploitation of CVE-2023-45860 in the wild and no public exploit code.
Other vulnerabilities in n/a
Sources
Also known as GHSA-8h4x-xvjp-vf99.