# CVE-2023-45860: Hazelcast Platform permission checking in CSV File Source connector

> Unauthorized clients can access data from files on the server filesystem due to inadequate permission checking in the CSV File Source connector.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 16 Feb 2024
- **Updated:** 6 Nov 2024
- **Also known as:** GHSA-8h4x-xvjp-vf99

## What is CVE-2023-45860?

CVE-2023-45860 is a medium-severity missing authorization vulnerability in n/a, published on 16 Feb 2024. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

In Hazelcast Platform through 5.3.4, a security issue exists within the SQL mapping for the CSV File Source connector. This issue arises from inadequate permission checking, which could enable unauthorized clients to access data from files stored on a member's filesystem.

Weakness: CWE-89 (Improper Neutralization of Special Elements used in an SQL Command)

## Which versions are affected by CVE-2023-45860?

12 open source packages ship an affected version, including com.hazelcast:hazelcast and com.hazelcast:hazelcast-enterprise. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `com.hazelcast:hazelcast` | Maven | All versions to 5.1.7 | None |
| `com.hazelcast:hazelcast` | Maven | All versions to 5.1.7 | None |
| `com.hazelcast:hazelcast` | Maven | From 5.2.0 | 5.2.5 |
| `com.hazelcast:hazelcast` | Maven | From 5.2.0 | 5.2.5 |
| `com.hazelcast:hazelcast` | Maven | From 5.3.0 | 5.3.5 |
| `com.hazelcast:hazelcast` | Maven | From 5.3.0 | 5.3.5 |
| `com.hazelcast:hazelcast-enterprise` | Maven | All versions to 5.1.7 | None |
| `com.hazelcast:hazelcast-enterprise` | Maven | All versions to 5.1.7 | None |
| `com.hazelcast:hazelcast-enterprise` | Maven | From 5.2.0 | 5.2.5 |
| `com.hazelcast:hazelcast-enterprise` | Maven | From 5.2.0 | 5.2.5 |
| `com.hazelcast:hazelcast-enterprise` | Maven | From 5.3.0 | 5.3.5 |
| `com.hazelcast:hazelcast-enterprise` | Maven | From 5.3.0 | 5.3.5 |

Products: Hazelcast Hazelcast.

## How do I fix CVE-2023-45860?

Upgrade com.hazelcast:hazelcast to a fixed version for your release line: 5.2.5 or 5.3.5.

## Is CVE-2023-45860 being exploited?

There is no known exploitation of CVE-2023-45860 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2020-26168](https://insights.sbomify.com/CVE-2020-26168/): Auth bypass in n/a (critical 9.8)
- [CVE-2022-36437](https://insights.sbomify.com/CVE-2022-36437/): Hazelcast connection caching (critical 9.1)
- [CVE-2023-33265](https://insights.sbomify.com/CVE-2023-33265/): Hazelcast Executor Services don't check client permissions properly (high 8.8)
- [CVE-2016-10750](https://insights.sbomify.com/CVE-2016-10750/): Deserialization of Untrusted Data in Hazelcast (high 8.1)
- [CVE-2023-45859](https://insights.sbomify.com/CVE-2023-45859/): Missing permission checks on Hazelcast client protocol (high 7.6)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-45860 and fix it if it is affected.

What it is: CVE-2023-45860 is a medium-severity missing authorization vulnerability in n/a, published on 16 Feb 2024. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-45860 in the wild and no public exploit code.

Affected packages and fixed versions:
- com.hazelcast:hazelcast (Maven): affected all versions up to 5.1.7; no fix listed
- com.hazelcast:hazelcast (Maven): affected all versions up to 5.1.7; no fix listed
- com.hazelcast:hazelcast (Maven): affected from 5.2.0; fixed in 5.2.5
- com.hazelcast:hazelcast (Maven): affected from 5.2.0; fixed in 5.2.5
- com.hazelcast:hazelcast (Maven): affected from 5.3.0; fixed in 5.3.5
- com.hazelcast:hazelcast (Maven): affected from 5.3.0; fixed in 5.3.5
- com.hazelcast:hazelcast-enterprise (Maven): affected all versions up to 5.1.7; no fix listed
- com.hazelcast:hazelcast-enterprise (Maven): affected all versions up to 5.1.7; no fix listed
- com.hazelcast:hazelcast-enterprise (Maven): affected from 5.2.0; fixed in 5.2.5
- com.hazelcast:hazelcast-enterprise (Maven): affected from 5.2.0; fixed in 5.2.5
- com.hazelcast:hazelcast-enterprise (Maven): affected from 5.3.0; fixed in 5.3.5
- com.hazelcast:hazelcast-enterprise (Maven): affected from 5.3.0; fixed in 5.3.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-45860/ (Markdown: https://insights.sbomify.com/CVE-2023-45860/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-45860
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-45860
- OSV: https://osv.dev/vulnerability/CVE-2023-45860

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-45860/
Summaries are generated and may contain mistakes; the official description above is the record.
