{"answers":{"affected":"2 open source packages ship an affected version, including com.rabbitmq:amqp-client. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-46120 exists.","fix":"Upgrade com.rabbitmq:amqp-client to 5.18.0 or later.","what":"CVE-2023-46120 is a medium-severity denial of service vulnerability in rabbitmq-java-client, published on 24 Oct 2023. An attacker needs administrator access to exploit it, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2023-46120 and fix it if it is affected.\n\nWhat it is: CVE-2023-46120 is a medium-severity denial of service vulnerability in rabbitmq-java-client, published on 24 Oct 2023. An attacker needs administrator access to exploit it, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-46120 exists.\n\nAffected packages and fixed versions:\n- com.rabbitmq:amqp-client (Maven): affected all versions; fixed in 5.18.0\n- com.rabbitmq:amqp-client (Maven): affected all versions; fixed in 5.18.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-46120/ (Markdown: https://insights.sbomify.com/CVE-2023-46120/index.md)","id":"CVE-2023-46120","markdown":"https://insights.sbomify.com/CVE-2023-46120/index.md","name":"CVE-2023-46120","record":{"aliases":["CLEANSTART-2026-RJ60135","CLEANSTART-2026-YW63019","DEBIAN-CVE-2023-46120","GHSA-mm8h-8587-p46h","MINI-pvmq-gr7x-fjp6","UBUNTU-CVE-2023-46120","openSUSE-SU-2024:13750-1"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"RabbitMQ Java client","requires_auth":"high_privilege","summary":"Attackers can cause a remote denial of service by sending large messages that exhaust memory in applications using the RabbitMQ Java client.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"rabbitmq_java_client","vendor":"vmware"}],"cvss":{"score":4.9,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-400","name":"Uncontrolled Resource Consumption"}],"description":"The RabbitMQ Java client library allows Java and JVM-based applications to connect to and interact with RabbitMQ nodes. `maxBodyLebgth` was not used when receiving Message objects.  Attackers could send a very large Message causing a memory overflow and triggering an OOM Error. Users of RabbitMQ may suffer from  DoS attacks from RabbitMQ Java client which will ultimately exhaust the memory of the consumer. This vulnerability was patched in version 5.18.0.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"RabbitMQ Java client's lack of message size limitation leads to remote DoS attack","id":"CVE-2023-46120","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"denial_of_service","year":"2023"},"n_packages":2,"n_references":4,"next":{"headline":"Generic Extractor MITM Vulnerability in yt-dlp","id":"CVE-2023-46121"},"packages":[{"ecosystem":"Maven","fixed":["5.18.0"],"introduced":["0"],"last_affected":[],"package":"com.rabbitmq:amqp-client","purl":null,"source":"GHSA-mm8h-8587-p46h"},{"ecosystem":"Maven","fixed":["5.18.0"],"introduced":["0"],"last_affected":[],"package":"com.rabbitmq:amqp-client","purl":"pkg:maven/com.rabbitmq/amqp-client","source":"GHSA-mm8h-8587-p46h"}],"prev":{"headline":"Parse Server may crash when uploading file without extension","id":"CVE-2023-46119"},"products":["rabbitmq-java-client"],"published":"2023-10-24","related":[{"cvss_score":6,"headline":"RabbitMQ: Malformed UTF-8 in shortstr properties permanently disables RPC consumers","id":"CVE-2026-106122","kev_date_added":null,"published":"2026-10-06"},{"cvss_score":5.7,"headline":"RabbitMQ Java client: plaintext broker credentials leaked in exception message from ConnectionFactoryConfigurator.load()","id":"CVE-2026-106123","kev_date_added":null,"published":"2026-10-06"},{"cvss_score":4.9,"headline":"RabbitMQ: JSONReader in the default JSON-RPC mapper never terminates on truncated input, causing DoS","id":"CVE-2026-106121","kev_date_added":null,"published":"2026-10-06"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-09-11","vendors":["rabbitmq"]},"summary":"Attackers can cause a remote denial of service by sending large messages that exhaust memory in applications using the RabbitMQ Java client.","url":"https://insights.sbomify.com/CVE-2023-46120/"}