{"answers":{"affected":"3 open source packages ship an affected version, including yt-dlp. It affects 1 product.","exploited":"There is no known exploitation of CVE-2023-46121 in the wild and no public exploit code.","fix":"Upgrade yt-dlp to 2023.11.14 or later.","what":"CVE-2023-46121 is a medium-severity server-side request forgery vulnerability in yt-dlp, published on 14 Nov 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2023-46121 and fix it if it is affected.\n\nWhat it is: CVE-2023-46121 is a medium-severity server-side request forgery vulnerability in yt-dlp, published on 14 Nov 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2023-46121 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- yt-dlp (PyPI): affected from 2022.10.04; fixed in 2023.11.14\n- yt-dlp (PyPI): affected from 2022.10.04; fixed in 2023.11.14\n- yt-dlp (PyPI): affected from 2022.10.04; fixed in 2023.11.14\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-46121/ (Markdown: https://insights.sbomify.com/CVE-2023-46121/index.md)","id":"CVE-2023-46121","markdown":"https://insights.sbomify.com/CVE-2023-46121/index.md","name":"CVE-2023-46121","record":{"aliases":["DEBIAN-CVE-2023-46121","GHSA-3ch3-jhc6-5r8x","PYSEC-2026-2063","UBUNTU-CVE-2023-46121","openSUSE-SU-2024:13435-1"],"analysis":{"component_type":"developer_tool","fix_type":"upgrade","impacts":["data_read","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"yt-dlp media downloader","requires_auth":"none","summary":"An attacker can force yt-dlp to use an arbitrary proxy, enabling Man-in-the-Middle attacks and potential cookie exfiltration.","user_interaction":"required","vuln_class":"ssrf"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"yt-dlp","vendor":"yt-dlp_project"}],"cvss":{"score":5,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:L/I:L/A:L","version":"3.1"},"cwes":[{"id":"CWE-444","name":"Inconsistent Interpretation of HTTP Requests"}],"description":"yt-dlp is a youtube-dl fork with additional features and fixes. The Generic Extractor in yt-dlp is vulnerable to an attacker setting an arbitrary proxy for a request to an arbitrary url, allowing the attacker to MITM the request made from yt-dlp's HTTP session. This could lead to cookie exfiltration in some cases. Version 2023.11.14 removed the ability to smuggle `http_headers` to the Generic extractor, as well as other extractors that use the same pattern. Users are advised to upgrade. Users unable to upgrade should disable the Ggneric extractor (or only pass trusted sites with trusted content) and ake caution when using `--no-check-certificate`.","ecosystems":["PyPI","openSUSE:Tumbleweed"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Generic Extractor MITM Vulnerability in yt-dlp","id":"CVE-2023-46121","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"ssrf","year":"2023"},"n_packages":4,"n_references":3,"next":{"headline":"Arbitrary file write via archive extraction (Zip Slip) vulnerability in sbt","id":"CVE-2023-46122"},"packages":[{"ecosystem":"PyPI","fixed":["2023.11.14"],"introduced":["2022.10.04"],"last_affected":[],"package":"yt-dlp","purl":null,"source":"GHSA-3ch3-jhc6-5r8x"},{"ecosystem":"PyPI","fixed":["2023.11.14"],"introduced":["2022.10.04"],"last_affected":[],"package":"yt-dlp","purl":"pkg:pypi/yt-dlp","source":"GHSA-3ch3-jhc6-5r8x"},{"ecosystem":"PyPI","fixed":["2023.11.14"],"introduced":["2022.10.04"],"last_affected":[],"package":"yt-dlp","purl":"pkg:pypi/yt-dlp","source":"PYSEC-2026-2063"},{"ecosystem":"openSUSE:Tumbleweed","fixed":["2023.11.16-1.1"],"introduced":["0"],"last_affected":[],"package":"yt-dlp","purl":"pkg:rpm/opensuse/yt-dlp\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2024:13435-1"}],"prev":{"headline":"RabbitMQ Java client's lack of message size limitation leads to remote DoS attack","id":"CVE-2023-46120"},"products":["yt-dlp"],"published":"2023-11-14","related":[{"cvss_score":8.8,"headline":"yt-dlp: Arbitrary Command Injection when using the `--netrc-cmd` option","id":"CVE-2026-26331","kev_date_added":null,"published":"2026-02-24"},{"cvss_score":8.4,"headline":"yt-dlp `--exec` command injection when using `%q` in yt-dlp on Windows","id":"CVE-2024-22423","kev_date_added":null,"published":"2024-04-09"},{"cvss_score":8.4,"headline":"yt-dlp command injection when using `%q` in `--exec` on Windows","id":"CVE-2023-40581","kev_date_added":null,"published":"2023-09-25"},{"cvss_score":8.3,"headline":"yt-dlp: Dangerous file type creation via insufficient filename sanitization (Bypass of CVE-2024-38519)","id":"CVE-2026-50023","kev_date_added":null,"published":"2026-06-23"},{"cvss_score":8.3,"headline":"yt-dlp: Arbitrary code execution via manifest downloads with aria2c","id":"CVE-2026-50574","kev_date_added":null,"published":"2026-06-23"},{"cvss_score":7.5,"headline":"yt-dlp: Downstream command injection via improper sanitization of yt-dlp --write-link output","id":"CVE-2026-55404","kev_date_added":null,"published":"2026-07-08"},{"cvss_score":7.5,"headline":"yt-dlp allows `--exec` command injection when using placeholder on Windows","id":"CVE-2025-54072","kev_date_added":null,"published":"2025-07-22"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-08-29","vendors":["yt-dlp"]},"summary":"An attacker can force yt-dlp to use an arbitrary proxy, enabling Man-in-the-Middle attacks and potential cookie exfiltration.","url":"https://insights.sbomify.com/CVE-2023-46121/"}