# CVE-2023-46121: Generic Extractor MITM Vulnerability in yt-dlp

> An attacker can force yt-dlp to use an arbitrary proxy, enabling Man-in-the-Middle attacks and potential cookie exfiltration.

- **Severity:** Medium 5.0 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 14 Nov 2023
- **Updated:** 29 Aug 2024
- **Also known as:** DEBIAN-CVE-2023-46121, GHSA-3ch3-jhc6-5r8x, PYSEC-2026-2063, UBUNTU-CVE-2023-46121, openSUSE-SU-2024:13435-1

## What is CVE-2023-46121?

CVE-2023-46121 is a medium-severity server-side request forgery vulnerability in yt-dlp, published on 14 Nov 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

yt-dlp is a youtube-dl fork with additional features and fixes. The Generic Extractor in yt-dlp is vulnerable to an attacker setting an arbitrary proxy for a request to an arbitrary url, allowing the attacker to MITM the request made from yt-dlp's HTTP session. This could lead to cookie exfiltration in some cases. Version 2023.11.14 removed the ability to smuggle `http_headers` to the Generic extractor, as well as other extractors that use the same pattern. Users are advised to upgrade. Users unable to upgrade should disable the Ggneric extractor (or only pass trusted sites with trusted content) and ake caution when using `--no-check-certificate`.

Weakness: CWE-444 (Inconsistent Interpretation of HTTP Requests)

## Which versions are affected by CVE-2023-46121?

3 open source packages ship an affected version, including yt-dlp. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `yt-dlp` | PyPI | From 2022.10.04 | 2023.11.14 |
| `yt-dlp` | PyPI | From 2022.10.04 | 2023.11.14 |
| `yt-dlp` | PyPI | From 2022.10.04 | 2023.11.14 |
| `yt-dlp` | openSUSE:Tumbleweed | All versions | 2023.11.16-1.1 |

Products: Yt-Dlp Project Yt-Dlp.

## How do I fix CVE-2023-46121?

Upgrade yt-dlp to 2023.11.14 or later.

## Is CVE-2023-46121 being exploited?

There is no known exploitation of CVE-2023-46121 in the wild and no public exploit code.

## Other vulnerabilities in yt-dlp

- [CVE-2026-26331](https://insights.sbomify.com/CVE-2026-26331/): yt-dlp: Arbitrary Command Injection when using the `--netrc-cmd` option (high 8.8)
- [CVE-2024-22423](https://insights.sbomify.com/CVE-2024-22423/): yt-dlp `--exec` command injection when using `%q` in yt-dlp on Windows (high 8.4)
- [CVE-2023-40581](https://insights.sbomify.com/CVE-2023-40581/): yt-dlp command injection when using `%q` in `--exec` on Windows (high 8.4)
- [CVE-2026-50023](https://insights.sbomify.com/CVE-2026-50023/): yt-dlp: Dangerous file type creation via insufficient filename sanitization (Bypass of CVE-2024-38519) (high 8.3)
- [CVE-2026-50574](https://insights.sbomify.com/CVE-2026-50574/): yt-dlp: Arbitrary code execution via manifest downloads with aria2c (high 8.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-46121 and fix it if it is affected.

What it is: CVE-2023-46121 is a medium-severity server-side request forgery vulnerability in yt-dlp, published on 14 Nov 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2023-46121 in the wild and no public exploit code.

Affected packages and fixed versions:
- yt-dlp (PyPI): affected from 2022.10.04; fixed in 2023.11.14
- yt-dlp (PyPI): affected from 2022.10.04; fixed in 2023.11.14
- yt-dlp (PyPI): affected from 2022.10.04; fixed in 2023.11.14

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-46121/ (Markdown: https://insights.sbomify.com/CVE-2023-46121/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-46121
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-46121
- OSV: https://osv.dev/vulnerability/CVE-2023-46121

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-46121/
Summaries are generated and may contain mistakes; the official description above is the record.
