# CVE-2023-46124: Server-Side Request Forgery Vulnerability in Custom Integration Upload

> A malicious user can exploit a Server-Side Request Forgery vulnerability in Fides to access internal systems and exfiltrate data via crafted YAML files.

- **Severity:** High 8.2 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:H/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 24 Oct 2023
- **Updated:** 11 Sep 2024
- **Also known as:** GHSA-jq3w-9mgf-43m4, PYSEC-2026-1344

## What is CVE-2023-46124?

CVE-2023-46124 is a high-severity server-side request forgery vulnerability in ethyca fides, published on 24 Oct 2023. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

Fides is an open-source privacy engineering platform for managing the fulfillment of data privacy requests in runtime environments, and the enforcement of privacy regulations in code. The Fides web application allows a custom integration to be uploaded as a ZIP file containing configuration and dataset definitions in YAML format. It was discovered that specially crafted YAML dataset and config files allow a malicious user to perform arbitrary requests to internal systems and exfiltrate data outside the environment (also known as a Server-Side Request Forgery). The application does not perform proper validation to block attempts to connect to internal (including localhost) resources. The vulnerability has been patched in Fides version `2.22.1`.

Weakness: CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2023-46124?

3 open source packages ship an affected version, including ethyca-fides. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `ethyca-fides` | PyPI | All versions | 2.22.1 |
| `ethyca-fides` | PyPI | All versions | 2.22.1 |
| `ethyca-fides` | PyPI | All versions | 2.22.1 |

Products: Ethyca Fides.

## How do I fix CVE-2023-46124?

Upgrade ethyca-fides to 2.22.1 or later.

## Is CVE-2023-46124 being exploited?

There is no known exploitation of CVE-2023-46124 in the wild and no public exploit code.

## Other vulnerabilities in ethyca fides

- [CVE-2024-45053](https://insights.sbomify.com/CVE-2024-45053/): Remote Code Execution Vulnerability via SSTI in Fides Webserver Jinja Email Templating Engine (critical 9.1)
- [CVE-2023-41319](https://insights.sbomify.com/CVE-2023-41319/): Remote Code Execution in Custom Integration Upload in Fides (high 8.8)
- [CVE-2025-57817](https://insights.sbomify.com/CVE-2025-57817/): Fides Webserver API is Vulnerable to OAuth Client Privilege Escalation (high 8.6)
- [CVE-2023-48224](https://insights.sbomify.com/CVE-2023-48224/): Cryptographically Weak Generation of One-Time Codes for Identity Verification in ethyca-fides (high 8.2)
- [CVE-2023-36827](https://insights.sbomify.com/CVE-2023-36827/): Fides vulnerable to Path Traversal in Webserver API (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-46124 and fix it if it is affected.

What it is: CVE-2023-46124 is a high-severity server-side request forgery vulnerability in ethyca fides, published on 24 Oct 2023. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-46124 in the wild and no public exploit code.

Affected packages and fixed versions:
- ethyca-fides (PyPI): affected all versions; fixed in 2.22.1
- ethyca-fides (PyPI): affected all versions; fixed in 2.22.1
- ethyca-fides (PyPI): affected all versions; fixed in 2.22.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-46124/ (Markdown: https://insights.sbomify.com/CVE-2023-46124/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-46124
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-46124
- OSV: https://osv.dev/vulnerability/CVE-2023-46124

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-46124/
Summaries are generated and may contain mistakes; the official description above is the record.
