# CVE-2023-46125: Fides Information Disclosure Vulnerability in Config API Endpoint

> Low-privileged users can access sensitive backend infrastructure details via the config API, exposing internal settings and database credentials.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 24 Oct 2023
- **Updated:** 11 Sep 2024
- **Also known as:** GHSA-rjxg-rpg3-9r89, PYSEC-2026-1347

## What is CVE-2023-46125?

CVE-2023-46125 is a medium-severity vulnerability in ethyca fides, published on 24 Oct 2023. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Fides is an open-source privacy engineering platform for managing the fulfillment of data privacy requests in a runtime environment, and the enforcement of privacy regulations in code. The Fides webserver API allows users to retrieve its configuration using the `GET api/v1/config` endpoint. The configuration data is filtered to suppress most sensitive configuration information before it is returned to the user, but even the filtered data contains information about the internals and the backend infrastructure, such as various settings, servers’ addresses and ports and database username. This information is useful for administrative users as well as attackers, thus it should not be revealed to low-privileged users. This vulnerability allows Admin UI users with roles lower than the owner role e.g. the viewer role to retrieve the config information using the API. The vulnerability has been patched in Fides version `2.22.1`.

Weakness: CWE-863 (Incorrect Authorization), CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2023-46125?

3 open source packages ship an affected version, including ethyca-fides. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `ethyca-fides` | PyPI | All versions | 2.22.1 |
| `ethyca-fides` | PyPI | All versions | 2.22.1 |
| `ethyca-fides` | PyPI | All versions | 2.22.1 |

Products: Ethyca Fides.

## How do I fix CVE-2023-46125?

Upgrade ethyca-fides to 2.22.1 or later.

## Is CVE-2023-46125 being exploited?

There is no known exploitation of CVE-2023-46125 in the wild and no public exploit code.

## Other vulnerabilities in ethyca fides

- [CVE-2024-45053](https://insights.sbomify.com/CVE-2024-45053/): Remote Code Execution Vulnerability via SSTI in Fides Webserver Jinja Email Templating Engine (critical 9.1)
- [CVE-2023-41319](https://insights.sbomify.com/CVE-2023-41319/): Remote Code Execution in Custom Integration Upload in Fides (high 8.8)
- [CVE-2025-57817](https://insights.sbomify.com/CVE-2025-57817/): Fides Webserver API is Vulnerable to OAuth Client Privilege Escalation (high 8.6)
- [CVE-2023-48224](https://insights.sbomify.com/CVE-2023-48224/): Cryptographically Weak Generation of One-Time Codes for Identity Verification in ethyca-fides (high 8.2)
- [CVE-2023-46124](https://insights.sbomify.com/CVE-2023-46124/): Server-Side Request Forgery Vulnerability in Custom Integration Upload (high 8.2)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-46125 and fix it if it is affected.

What it is: CVE-2023-46125 is a medium-severity vulnerability in ethyca fides, published on 24 Oct 2023. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-46125 in the wild and no public exploit code.

Affected packages and fixed versions:
- ethyca-fides (PyPI): affected all versions; fixed in 2.22.1
- ethyca-fides (PyPI): affected all versions; fixed in 2.22.1
- ethyca-fides (PyPI): affected all versions; fixed in 2.22.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-46125/ (Markdown: https://insights.sbomify.com/CVE-2023-46125/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-46125
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-46125
- OSV: https://osv.dev/vulnerability/CVE-2023-46125

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-46125/
Summaries are generated and may contain mistakes; the official description above is the record.
