{"answers":{"affected":"2 open source packages ship an affected version, including crypto-es. It affects 1 product.","exploited":"There is no known exploitation of CVE-2023-46133 in the wild and no public exploit code.","fix":"Upgrade crypto-es to 2.1.0 or later.","what":"CVE-2023-46133 is a critical vulnerability in entronad crypto-es, published on 25 Oct 2023. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2023-46133 and fix it if it is affected.\n\nWhat it is: CVE-2023-46133 is a critical vulnerability in entronad crypto-es, published on 25 Oct 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2023-46133 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- crypto-es (npm): affected all versions; fixed in 2.1.0\n- crypto-es (npm): affected all versions; fixed in 2.1.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-46133/ (Markdown: https://insights.sbomify.com/CVE-2023-46133/index.md)","id":"CVE-2023-46133","markdown":"https://insights.sbomify.com/CVE-2023-46133/index.md","name":"CVE-2023-46133","record":{"aliases":["GHSA-mpj8-q39x-wq5h"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"JavaScript crypto library","requires_auth":"none","summary":"CryptoES library uses weak PBKDF2 defaults, allowing attackers to easily crack protected passwords or forge signatures.","user_interaction":"not_required","vuln_class":"weak_cryptography"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"cryptoes","vendor":"entronad"}],"cvss":{"score":9.1,"severity":"critical","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-327","name":"Use of a Broken or Risky Cryptographic Algorithm"},{"id":"CWE-916","name":"Use of Password Hash With Insufficient Computational Effort"},{"id":"CWE-328","name":"Use of Weak Hash"}],"description":"CryptoES is a cryptography algorithms library compatible with ES6 and TypeScript. Prior to version 2.1.0, CryptoES PBKDF2 is 1,000 times weaker than originally specified in 1993, and at least 1,300,000 times weaker than current industry standard. This is because it both defaults to SHA1, a cryptographic hash algorithm considered insecure since at least 2005, and defaults to one single iteration, a 'strength' or 'difficulty' value specified at 1,000 when specified in 1993. PBKDF2 relies on iteration count as a countermeasure to preimage and collision attacks. If used to protect passwords, the impact is high. If used to generate signatures, the impact is high. Version 2.1.0 contains a patch for this issue. As a workaround, configure CryptoES to use SHA256 with at least 250,000 iterations.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"crypto-es PBKDF2 1,000 times weaker than specified in 1993 and 1.3M times weaker than current standard","id":"CVE-2023-46133","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"weak_cryptography","year":"2023"},"n_packages":2,"n_references":2,"next":{"headline":"D-Tale vulnerable to Remote Code Execution through the Custom Filter Input","id":"CVE-2023-46134"},"packages":[{"ecosystem":"npm","fixed":["2.1.0"],"introduced":["0"],"last_affected":[],"package":"crypto-es","purl":null,"source":"GHSA-mpj8-q39x-wq5h"},{"ecosystem":"npm","fixed":["2.1.0"],"introduced":["0"],"last_affected":[],"package":"crypto-es","purl":"pkg:npm/crypto-es","source":"GHSA-mpj8-q39x-wq5h"}],"prev":{"headline":"Crosslinking transaction attack in hyperledger/fabric","id":"CVE-2023-46132"},"products":["crypto-es"],"published":"2023-10-25","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2024-09-10","vendors":["entronad"]},"summary":"CryptoES library uses weak PBKDF2 defaults, allowing attackers to easily crack protected passwords or forge signatures.","url":"https://insights.sbomify.com/CVE-2023-46133/"}